0

I want to change the access permissions for MP3 files on an external 2,5" HDD on my Raspberry Pi on which I run an actual version of Raspian.

To do so I tried to use the following command:

find /Path/ -type f -exec chmod 755 {} \;

But after execution I get the following error for each file:

chmod: changing permissions of /Path/File.mp3: Operation not supported

I also tried it with root permissions but it didn´t help. I access the HDD via /media/HDDName if this can be important. I can view the files and already changed the Permissions of all folders above the MP3 files.

1

Your external hard disk is likely using fat32 or a similar file system that doesn't support setting these permissions.

In any case, making a mp3 file executable is at least dubious.

7
  • So i should change my file system to do so? Which one do you recommend? What do you mean with dubious?
    – ElBroiler
    Jul 31 '15 at 22:58
  • What is the problem you are trying to solve with this command? By dubious I mean pointless.
    – jlliagre
    Aug 1 '15 at 1:22
  • @ElBroiler: What @jlliagre means is, you really don't need x permission for a mp3 file to play. You just need to read it. 755 means rwxr-xr-x
    – neuron
    Aug 1 '15 at 5:47
  • Ahhh, well, I am new to UNIX so I thought that I need the right to execute it too. Why is this not necessary?
    – ElBroiler
    Aug 1 '15 at 7:20
  • That is not necessary because a MP3 is not a program but just data. This is true regardless of the OS
    – jlliagre
    Aug 1 '15 at 10:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.