0

I am not able to ftp to the server from a client.  I can ping the server from VM, can ssh as well, but cannot ftp.  I am using my base machine as Ubuntu 14.04. Below is the ifconfig output:

raghav@raghav-HP-15-Notebook-PC:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 38:63:bb:e5:ee:29  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:6302 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6302 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:603664 (603.6 KB)  TX bytes:603664 (603.6 KB)

ra0       Link encap:Ethernet  HWaddr c0:38:96:7f:5c:97  
          inet addr:192.168.1.5  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::c238:96ff:fe7f:5c97/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:354373 errors:0 dropped:0 overruns:0 frame:0
          TX packets:69134 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:121914289 (121.9 MB)  TX bytes:12476694 (12.4 MB)
          Interrupt:16 

vmnet1    Link encap:Ethernet  HWaddr 00:50:56:c0:00:01  
          inet addr:192.168.5.1  Bcast:192.168.5.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:178 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

vmnet8    Link encap:Ethernet  HWaddr 00:50:56:c0:00:08  
          inet addr:172.16.172.1  Bcast:172.16.172.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:85 errors:0 dropped:0 overruns:0 frame:0
          TX packets:177 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Now I have installed VM player on the machine and configured RHEL 6 Server with the below configuration:

raghav@raghav-HP-15-Notebook-PC:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 38:63:bb:e5:ee:29  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:6302 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6302 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:603664 (603.6 KB)  TX bytes:603664 (603.6 KB)

ra0       Link encap:Ethernet  HWaddr c0:38:96:7f:5c:97  
          inet addr:192.168.1.5  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::c238:96ff:fe7f:5c97/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:354373 errors:0 dropped:0 overruns:0 frame:0
          TX packets:69134 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:121914289 (121.9 MB)  TX bytes:12476694 (12.4 MB)
          Interrupt:16 

vmnet1    Link encap:Ethernet  HWaddr 00:50:56:c0:00:01  
          inet addr:192.168.5.1  Bcast:192.168.5.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:178 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

vmnet8    Link encap:Ethernet  HWaddr 00:50:56:c0:00:08  
          inet addr:172.16.172.1  Bcast:172.16.172.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:85 errors:0 dropped:0 overruns:0 frame:0
          TX packets:177 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

On the server I have deployed a VM RHEL 6 with following configuration:

Ipaddr: 192.168.122.217

While configuring the network NAT protocol was used. Help would be appreciated.

  • Please let me know if any further info is required from my side. I can ping the server from VM , can ssh as well. but cannot ftp – Raghav Chadha Jul 31 '15 at 18:40
1

Appears you need to install ftp. Such an insecure protocol isn't installed/enabled by default on RHEL 6.

yum install proftpd will install ftp.

| improve this answer | |
  • 1
    Hey steve thanksfor thr ans. Indeed i requireD the install the ftp service. For that i installed vsftpd. Also had to work with SElinux to be disaed for aome ftp directories. And it started working. – Raghav Chadha Aug 2 '15 at 20:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.