0

I keep getting error:plug in needed to view content when ever I want to watch certain videos on certain sites... this was just a matter of installing flash-plug in on my fedora 22 laptop. But when I try to install it on my Centos 6.6 laptop I'm getting this in the terminal :

[root@horriblehost /]# yum install flash plug-in
Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: centos.aol.com
 * extras: mirrors.sonic.net
 * rpmforge: mirror.chpc.utah.edu
 * updates: centos.mirror.constant.com
http://linux.dropbox.com/fedora/6/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: Dropbox. Please verify its path and try again
[root@horriblehost /]# 

I'm not sure why references to dropbox keep popping up. My dropbox is working... Any help? I would really like to get flash working. I'm new to this Linux thing ( but loving it).

2 Answers 2

0

Have you configured your CentOS 6.6 to use a repository that contains flash-plugin, RepoForge for example?

The dropbox error occurs because http://linux.dropbox.com/fedora/6/repodata/repomd.xml does not exist. CentOS is not listed at http://linux.dropbox.com. You can disable the repository temporarily with:

yum install flash-plugin --disablerepo=Dropbox

or make it persistent by setting:

enabled=0

in /etc/yum.repos.d/Dropbox.repo or whatever the dropbox repo file is named.

EDIT:

Please note that Flash is unsupported on Linux. This link provides more information.

As requested, here are some informational links about repositories and YUM:

Adding a repository

Setup and Use repositories

YUM HowTo

1
  • This worked for installing flash-plugin! The --disablerepo=Dropbox worked like a charm. I will disable the repo for good next. Thank you. I'm still not sure how the repo thing works, suggestions for reading? I tried to up vote your answer but I guess I don't have much of a reputation around here, lol...
    – Sinux1
    Commented Jul 31, 2015 at 18:02
0

In the syntax of the command you have written, yum is attempting to install two packages: flash and plug-in.

You got the name wrong. Try yum install flash-plugin.

NOTE: Alternatively, you can install Adobe Flash player manually from their website, untar the file, copy libflashplayer.so to ~/.mozilla/plugins, and copy all of the files provided in usr (from the untar'd flash player file) to /usr using cp usr/* /usr.

1
  • when I try copying /usr* to /usr it says 'omitting' to every file it tries to copy ( there are three in there)
    – Sinux1
    Commented Jul 31, 2015 at 17:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .