2

So I'm trying to set up a Rocks cluster and seem to be failing at the network configuration part, as I can not get an internet connection in my final install.

So the address of that computer that shows up on my router is 192.168.0.124 and I used this as the IP in the first set up, shown here 192.168.0.124/255.255.255.0

I have also tried 192.168.0.1 and 192.168.0.130 (a random address in range). From a windows machine hooked up to the same network I can see that my netmask is 255.255.255.0. It also shows my default gateway as 192.168.0.1

Then I get to the private network and leave it at the defaults. I have tried other address too but I am unsure of what to do. There is just a network switch there in which I'd hook up all my computers to. default values Finally I get to the screen about the gateway and DNS. From the Windows machine that is hooked up to the same network I run

ipconfig /all

and I get that the gateway and DNS servers are both on 192.168.0.1, so I used these.192.168.0.1

My question is how do I set these up properly? How can I find out the addresses that I need to use? I haven't found any help from Google and this is the only part of the puzzle that I am missing.

I am installing as to the instructions of this youtube video but I am using different networking options.

My computer has an Ethernet connection on the mother board and one through a PCI-E slot. I have assumed that the computer is recognizing the PCI as eth1 and the motherboard connection as eth0. I have also booted into an Arch live cd on the machine, which can ping Google, and running ifconfig I see

enp4s6 with inet 192.168.0.124 and netmask 255.255.255.0

enp6s0 with no inet or addresses.

The ethernet conencted to the public network is connected to the network card in the PCI-E slot and the ethernet connected to the switch is on the motherboard port.

I appreciate any help. Thanks.

1 Answer 1

1

So I figured out that the problem was actually in that the different OS's loaded the NIC in different orders. Arch had loaded the PCI-E network card as enp4s6 and the motherboard card as enp6s0. How I figured this out was that when in the CentOS install I ran

ethtool eth0; ethtool eth1

and I noticed the different speeds. The cards had similar names so I had missed this but the PCI-E card was 100Mbps and the motherboard interface was a gigabit. The Arch live usb showed the reverse order.

And for anyone else that runs across this problem, here are some useful tools and places to look to help debug

/etc/hosts
/etc/resolve.conf
/etc/nsswitch.conf
ip addr show
ip route show
route
netstat -nr
arp -e
ethtool <interface>

In short, it was a stupid mistake on my part. I did not see any networking tools in the Rocks install (Anaconda installer) and it may just be easier to debug from a bad install where you have terminal access.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .