2

I have an old SGI indigo with an EFS file system (Extent File System ), and the password needs to be reset. I can mount the hard drive, but read-only. I need write permissions.

# mount --rw -t efs /dev/sdb1 Filesystem 
mount: warning: Filesystem seems to be mounted read-only.


# mount -o remount,rw -t efs /dev/sdb1 Filesystem
mount: Filesystem/ not mounted or bad option

I have tried the force option, but it did not effect anything.

I am using Ubuntu 14.04. Mate yes, I have everything backed up.

How can I force the drive to mount with write permissions?

  • If you run a Google search for "Vetusware IRIS" you'll find SGI's source code which contains the sources for the original EFS. No promises, but you might be able to use them to compile EFS with read-write privileges. – Alhadis Oct 4 '18 at 17:05
2

Is Filesystem the mount point?

You could try the mount -o remount,rw -t efs /dev/sdb1 Filesystem option to remount the filesystem as read-write.

  • yes, Filesystem is the mount point. # mount -o remount,rw -t efs /dev/sdb1 Filesystem/ mount: Filesystem/ not mounted or bad option – j0h Jul 30 '15 at 13:04
  • What about mount -o rw -t efs /dev/sdb1 Filesystem? – dr01 Jul 30 '15 at 13:19
  • # mount -o rw -t efs /dev/sdb1 Filesystem/ mount: warning: Filesystem/ seems to be mounted read-only. – j0h Jul 30 '15 at 13:33
  • 1
    Do not terminate Filesystem with a / – Marco Jul 30 '15 at 13:38
2

I have bad news for you: if I'm reading the code in http://lxr.free-electrons.com/source/fs/efs/ correctly, Linux -- even the very newest version -- does not implement write access to EFS, probably because it was believed that the only use for a filesystem that old was to migrate data off of old disks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.