2

I have mpd running as a system service and as user mpd. Since mpd is a system service and pulse audio is session-based, I have to stream music from mpd to the currently active pulse session daemon. This is done using the module-native-protocol-tcp module configured with auth-anonymous=1 auth-cookie-enabled=0 listen=0.0.0.0 (loose, I know, but for testing purposes)

The output in mpd.conf looks like this:

audio_output {                                                                   
  type    "pulse"                                                                
  name    "My (loopback) Pulse Output"                                           
  server  "localhost"                                                            
}   

Now when I run a song in mpd it complains:

pulse_output: "My (loopback) Pulse Output" [pulse] failed to play: suspended
output: Failed to open audio output

What is wrong here? Is this a bug?

What I tried : Running as my user (systemd) Running as my user (systemd) and set the user in mpd.conf Running as root and set the user in mpd.conf Setting the exact sink name

0

You seem to understand what is going on better than I do, but I had the same error message, and the problem disappeared following the instructions on this wiki page (also relayed at AskUbuntu) :

Using the same mpd.conf as you do.

Uncomment the following lines from /etc/pulse/default.pa (you might need to add the part which specified the IP address to the line):

load-module module-native-protocol-tcp auth-ip-acl=127.0.0.1 # IP of localhost

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.