8

I've just installed OpenSuse 13.2 on my xps13. The resolution is a whopping 3200 x 1800. Which causes the text to come up tiny... Any way for me to scale this without having to lower the resolution (I'd like to keep that for watching movies etc.).

update: I've changed the dpi setting of fonts, which was in system settings as an option. It help a lot already, but some applications and menus just don't adjust... See below:

enter image description here

  • Set the fonts bigger, maybe? 16 to 20 would be nice I think. – McSinyx Jul 29 '15 at 14:21
  • I tried that, but the windows remain tiny and the fonts pop out of their bars – dorien Jul 29 '15 at 14:30
  • 1
    maybe something about dpi setting? – dorien Jul 29 '15 at 14:30
  • 1
    Check out official community wiki page community.kde.org/KDE/High-dpi_issues – contemplator Jul 29 '15 at 20:33
  • Heh. I had a similar reaction when I first bought a 2k monitor. I traded it in for a bigger 2k monitor...32 inches I think it was. Text was nicely sized then. :) – B Layer Aug 4 '17 at 16:47
4

With KDE 4 atleast you can adjust the font sizes (and/or DPI settings) in 'Application' > 'Fonts' enter image description here

To scale some other parts of the display, you can also change the icon size at 'Application' > 'Icons' as well. This is the method suggested for doing this in the Arch Wiki

Note you will need to restart the desktop and applications for it to take effect.

Another method (from the KDE Wiki), is to configure the X DPI settings:

Ideally the screen size (width and height of the monitor screen) is automatically detected using the monitor's EDID information. This may not work correctly or not be to the user's preferences. KDE currently lacks a convenient way to scale everything uniformly. Such a feature would also help to test proper scaling behaviour.

Workaround:

Modify the X server's settings. In /etc/X11/xorg.conf add DisplaySize and Option "UseEdidDpi" to the monitor section so that it looks somewhat like this:

Section "Monitor"
  Identifier   "Monitor0"
  VendorName   "Monitor Vendor"
  ModelName    "Monitor Model"
  Option       "UseEdidDpi"    "false"
  DisplaySize  464 292
EndSection

where the display size (width and height) is in millimeters. The DPI value is then calculated from these numbers and the monitor image's resolution in pixels. Use smaller numbers than the real dimension to simulate high DPI (make everything appear larger) or bigger numbers for low DPI (make everything appear smaller). The X server needs to be restarted for the changes to take effect.

To make things more interesting, many distributions these days do not create a /etc/X11/xorg.conf file, used to configure the X server, by default. The X configuration is automatically determined each time X is started. In most cases, this works well and there is no need to manually specify X configuration information. To create it, run as root

Xorg :1 -configure

then copy xorg.conf.new to /etc/X11/xorg.conf and modify it as shown above.

A similar method is also demonstrated on AU here.

KDE is made up of large amount of old components, which probably restrict the support available for DPI screens until the components are updated (list of things that need doing here) - some bits may be better in the new KDE 5 though.
However other desktop environments I think have supported HiDPI for a while, such as Gnome (since 3.10), you could try other DEs to see if support is better there. Under Gnome (and probably Gnome Classic as well), you should be able to adjust the scaling setting via Gnome Tweak Tool.

See also: Can Linux deal with ultra high resolution displays?

  • In fact, I changed the dpi settings on this page. The result is that many window sizes and boxes do not scale along, which makes for odd line breaks and things popping out of their boxes. It would be good to have a general dpi setting (not just for fonts) – dorien Jul 30 '15 at 11:19
  • Thanks for the addition. I've tried this and things popped up too big. Mmmm maybe some of my display size was incorrect. – dorien Jul 31 '15 at 11:01
  • [Kubuntu 16.04] I've changed ten xorg.conf settings and unfortunately not every program scale good. KDE panel, and kde apps are ok. Skype is also ok. But Firefox, Eclipse have still very small fonts. – s.paszko Dec 23 '16 at 8:51
  • @s.paszko - I haven't tried since KDE plasma, but I think in KDE you still need to make sure settings are also done for GTK apps (look for "GTK..." in KDE settings or login a GTK desktop and try there). KDE uses QT for the interfaces - I am used to doing the opposite for KDE apps such as K3B in Gnome/Xfce). Gnome can do DPI scaling using the tweak tool program but I am not sure if this works outside of Gnome. – Wilf Dec 23 '16 at 19:43
3

For KDE 5.28 on (K)ubuntu 16.04, I've needed to set both Display scaling under System Settings → Display and Monitor → Display Configuration → Scale Display and I've needed to set the font dpi manually under System Settings → Fonts → Force fonts DPI. That helped for KDE applications, but also e.g. for Firefox and Chrome.

Maybe someone could edit this to show authentic English text.

  • The fonts DPI is not needed in Kubuntu 18.04 anymore. – Falko Menge Apr 11 at 20:26
0

The best solution of scaling I found so far - is just set resolution to lower (2k instead of original 4k of my laptop). I don't see any blurriness - it is exactly the same as with my 2k display laptop, maybe even better. So my first advice - just lower your resolution.

I'm using plasmashell 5.8.7

  • Not quite the same when watching blueray. Extreme sharpness is the point of this screen right :) hope they fix it soon. – dorien Aug 4 '17 at 16:26
  • I have two dell XPS 9560 laptops in front of me, one with 2k and one with 4k. 2k is less precise than 4k, for sure. But downscaled not worse than original 2k, it's the same or even little bit better. And definitely much better for work, than all the scaling settings, because most applications doesn't support them well. – DmitryBorodin Aug 4 '17 at 23:34
  • I see. Interesting! – dorien Aug 5 '17 at 4:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.