2

I'm running VIM under GNU screen. When I'm in insert mode and press e.g. asterisk symbol on numeric keyboard, instead of asterisk I get <F3>, when I press e.g. 4 I get t followed by newline. My TERM is set to screen. Same thing happens when VIM is not under screen and TERM is set to xterm. VIM is version 7.3.547. Screen is version 4.00.03jw4 (FAU) 2-May-06. Where is the problem? I'm connecting to OS via Putty. I've find this answer which suggests:

Preferences->Profiles->Keys and load preset of: xterm with numeric keypad.

The problem is I do not know where are those preferences.

2

I've found solution here. In general:

  • Run PuTTY Configuration.
  • In the left pane, select Terminal, Features.
  • Put a check mark next to "Disable application keypad mode".
  • In the left pane, select Session.
  • Save the settings.
  • NOTE: The bug is that Vim enables Application Keypad Mode without defining any mappings for it. I haven't found an explanation for this behavior. PuTTY, Terminal and XTerm are behaving correctly: they emulate a terminal with AKM and Vim asks for it to be enabled, so it is. – Chris Page Dec 10 '15 at 12:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.