1

It worked fine till yesterday all of sudden it is unable discover nearby access points.Even I tried to connect to manually it didn't work

lspci | grep BCM
07:00.0 Network controller: Broadcom Corporation BCM43142 802.11b/g/n (rev 01)

lsmod | grep wl
wl                   6369280  0 
cfg80211              548864  1 wl
  • try running "rfkill list" and check that your device is not hard blocked or soft blocked – AphroditeVenus Aug 10 '15 at 1:49
0

Most probably you have to install Boradcom drivers to get the correct behavior. I had the same issue and after few tries I could install the drivers and issue is gone.

Install RPMFusions free and non free versions using these two commands. Change version number (22) according to your version. My installed fedora version is 22.

rpmkeys --import "http://rpmfusion.org/keys?action=AttachFile&do=get&target=RPM-GPG-KEY-rpmfusion-free-fedora-22" "http://rpmfusion.org/keys?action=AttachFile&do=get&target=RPM-GPG-KEY-rpmfusion-nonfree-fedora-22"

Then

dnf install http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-22.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-22.noarch.rpm

Now your *.rpms are ready. Lets continue to install the drivers. Run below command to install the necessary packages.

 dnf install kmod-wl akmod.wl kernel_devel

Here is the step by step guide.http://codeketchup.blogspot.sg/2015/12/how-to-install-broadcom-drivers-in.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.