1

Troubles getting my sound setup to work on a fresh install of Debian/Jessie.

The RME Multiface is an external rack mounted Pro Audio interface with a ton of channels and connectors (18 output channels), running up to 24bit /96kHz. Admitted, it is over 10 years old, but still offers competitive fine pro sound quality. RME used to be Linux friendly, so at that time a lot of audio oriented Liunx folks used these interfaces. Thus my question: does anyone know how to take that new hurdle?

Obviously, this new hurdle is the combination of systemd and PulseAudio. And in addition, OSS as a fallback is slowly going away.

Problems

  1. interface can not be initialised (solved)
  2. no sound in VLC. OSS interface is gone.
  3. PulseAudio unable to deal with the HDSP ("Hammerfall DSP" is the name of the interface used to connect to the external rack mounted RME Multiface)
  4. interface dead after Hibernation, but unable to remove and reload kernel module

Problem 1 is solved. It turned out that Debian actually never packaged and shipped the Linux specific RME firmware. I just happened to have a DEB package from the glorious old 64studio distribution lying around on my old system. Solution is

  • get the firmware loader and hdsp matrix mixer (from official Debian)

    apt-get install alsa-tools-gui alsa-firmware-loaders

  • get the Firmware from Alsa.org, build and install (NOTE the prefix /usr, otherwise the DEB-packaged firmware loader won't find it)

    tar xf alsa-firmware-1.0.29.tar.bz2 
    cd alsa-firmware-1.0.29/
    ./configure --prefix=/usr
    make
    sudo make install`
    

Now, when loading the kernel module (modprobe snd_hdsp), the firmware will automatically be downloaded into the Multiface. Basic playback works. Jack Audio works.

Problem 2 seems to be that VLC is no longer built with OSS support. The only way I got to work is to install the vlc-plugin-jack and play through Jack, which is kind of convoluted just to watch some video. My guess is, if I manage to solve Problem 3, this will also be solved.

Problem 3: PulseAudio lists only the on board soundcard, which I haven't hooked up to any speaker (and wont). On startup, PulseAudio probes the HDSP card in numerous ways, but fails. Fun fact is, Alsa has no problem getting sound to the card. So the question is: does anyone know how to get PulseAudio to connect to that card?

Problem 4: after Hibernation, the kernel driver has usually lost the connection to the external firmware in the Multiface. Playback remains mute. Previously, I was able to resolve that situation by removing and reinstalling the kernel module (rmmod snd_hdsp; modprobe snd_hdsp), which would re-load the firmware if necessary. But unfortunately now the use-cound of the module snd_hdsp is always at least 1. Even if PulseAudio is killed and all sound applications are closed. Incidentally, the snd_hda (the kernel module for the Intel on board soundcard) has also use-cnt 1. Any idea what could keep that module open?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.