0

I am trying to setup X11Forwarding between my Arch Linux ARM server and my OSX computer.

I am accessing the server locally (always).

/etc/ssh/ssh_config:

X11Forwarding yes
AddressFamily any
PermitRootLogin yes
X11UseLocalhost yes

ssh -X -A root@myserver.local -v

...
X11 forwarding request failed on channel 0
...

xorg-xauth is installed so i assume that this problem can be excluded. Furthermore X11 starts smoothly on the client side when connecting via. SSH.

Why is it failing?

UPDATE

Unfortunately i have been editing the wrong file all along, which should have been sshd_config and not ssh_config.

enter image description here

1

2 shots:
1. Perhaps login as root is denied (that's the default setting on many systems and it is pretty reasonable). Did you tried with a different user?
2. Did you try sshing with ssh -Y?

  • I tried a secondary user, unfortunately the same problem. I have tried with -Y with the same result.. – JavaCake Jul 26 '15 at 19:07
  • Does journalctl -r --unit sshd reveal anything interesting? – Dave's tux Jul 26 '15 at 19:11
  • Unfortunately no, it looks very clean.. – JavaCake Jul 26 '15 at 19:12
  • Did you try setting X11UseLocalhost? – Dave's tux Jul 26 '15 at 19:14
  • I have just tried, same result. It should be enough to systemctl restart sshd? – JavaCake Jul 26 '15 at 19:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.