I've recently taken the plunge and gone from Ubuntu to Fedora. When connected to my wireless network my web browsers can't access any sites although skype works fine. I don't have the problem when connected to a network by a wire. I'm guessing it is some sort of DNS problem but I don't know how to fix it.

Any suggestions?

  • 2
    There is a good guide to troubleshooting your networking here: unix.stackexchange.com/questions/5958/… It specifically has a section on DNS that you might want to try. Oct 1, 2011 at 12:30
  • More important than the distribution is your network management tool (GUI). You should find out what it is and include the information. Oct 1, 2011 at 16:54
  • Thanks all. The network manager didn't save my new DNS server details in resolv.conf. I opened it and did it myself and it works now.
    – Darling
    Oct 2, 2011 at 8:49

1 Answer 1


Your problem definitely seems to lie in DNS configuration. The great general troubleshooting guide written by Shawn contains a lot of useful information and based on it, you might verify whether the problem is connected with DNS. Adding to Shawn's suggestions, I'd recommend you to try manually resolving a hostname using host like this (microsoft.com is just a nice example ;) ) :

host microsoft.com

(this should yield no result if the DNS servers are not configures properly) and then

host microsoft.com

-this time you tell the host tool explicitly what name server it should query. This should work regardless of what your /etc/resolv.conf file contains.

Also, the fact that your wired connection works fine might be both a clue and a means of investigating the issue further. I suggest you do:

  1. Connect though wire, verify web browsing works and then copy your /etc/resolv.conf to some temporary place like /tmp/resolv1.

  2. Disconnect the wire and connect via wireless. After establishing a connection (you can do a ping to test that), copy the contents of /etc/resolv.conf to a second temporary file, say tmp/resolv2.

  3. Compare the two copied files. The first one should contain proper name servers, the second might contain none or a single improper entry such as your gateway address (typically or

By now you probably understand why name resolution (typically needed for web browsing) does not work with your wireless configuration. However, it might be not obvious where the problem origins from.

Typically (n standard desktop distributions), the networking is controlled by a GUI program like NetworkManager or wicd. This tools are used to easily define how wired and wireless interfaces should connect to the network and, in each case, what information should be queried from the DHCP server.

So, finally, I believe that to solve your problem you just need to open up your network configuration GUI program and check how the configuration options for wired and wireless interface differ. It could be, for example, that the wired interface simply uses static configuration of both IP address and DNS. Another option is that both interfaces use DHCP, but one has some option ticked to use static DNS (those may be defined elsewhere).

  • Thanks,it was a DNS problem. I saved a copy of resolv.conf then changed the DNS server addresses to that of openDNS and it worked. For some reason the network manager gui didn't edit the file when I gave it new servers.
    – Darling
    Oct 2, 2011 at 8:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .