5

Trying to retrieve a password from KWallet, I found that I couldn't open KWalletManager. Neither the menu item System > KWalletManager, nor Alt+F2 and typing in kwalletmanager do anything. Does anybody have any idea what I can do?

When I run kwalletmanager from the command line, it outputs

QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.

but I read that that is just a warning, not the cause of the program refusing to start at all.

Also, when I use the wallet from within another application, there is no wallet icon in the system tray, even though the checkbox "Show manager in system tray" is checked in the system settings.

It sounds like I'm missing something.
Considered uninstalling and reinstalling KWallet from the repository, but seeing the amount of software that needs to be removed if I uninstall it, I hesitate to do that. Anybody have any ideas what I can try?


Edit: this has turned into a whole new question now. As originally written, the question was

I thought I knew my password on one ftp site, but apparently not. How do I tell Konqueror to show me what it is?

I'm running Debian 7.8 KDE (and yes, I know I need to update to Jessie, I just haven't brought myself to do it yet).

  • Isn't Konqueror storing it's passwords in KDE Wallet? – sam_pan_mariusz Jul 25 '15 at 17:00
  • Then my question is, how do I get kwallet to show me my passwords. I've got an item KWalletManager in the System menu, but it doesn't do anything. – Mr Lister Jul 25 '15 at 17:45
3

Open KWalletManager (/usr/bin/kwalletmanager) in KDE, go to Contents / Form Data / Maps, select the correct id, check Show Values box. Works for me.

If you can't find it this way: save your login page to a HTML file, place it on a localhost webserver with PHP/CGI support, trick your resolver via /etc/hosts to call local page instead of the original, write a simple PHP/CGI script to display form data and attach it in saved HTML page under <form action=...>. Then login.

  • kwallwetmanager doesn't do anything. If I run it from the command line, it outputs "QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave." twice, and it does nothing else. Is there something I need to reinstall? – Mr Lister Jul 25 '15 at 18:03
  • If I run it with sudo, it gives the above error and then says "unnamed app(11156): KUniqueApplication: Cannot find the D-Bus session server: "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." – Mr Lister Jul 25 '15 at 18:05
  • A strange issue I've seen before in Ubuntu. Can't remember how solved it. Doesn't an icon appear in your systray? What's your distro? And running with sudo makes little sense here. – sam_pan_mariusz Jul 25 '15 at 18:12
  • Oh sorry, I hadn't mentioned that yet. Debian 7.8 KDE. And I do know running as root will not be of use in this case, but I am used to sudoing whenever an application gives out an error message and won't run! So it was more an instinctive reaction than anything else. Anyway, I still think I need to reinstall something. Or more likely, upgrade the whole system. – Mr Lister Jul 25 '15 at 18:30
  • And when you run /usr/bin/kcmshell4 kwalletconfig, does the window appear? What happens when you click Launch Manager button? – sam_pan_mariusz Jul 25 '15 at 19:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.