I have installed google noto fonts in /usr/share/fonts/opentype/noto .and execute the command:

fc-cache -fv

1.How to know which type of fonts is being used in my debian8.1?
2.How to set google noto fonts to be used in my debian8.1?How to set the configuration file /etc/fonts/fonts.conf ?

enter image description here


From Set system font in LXDE?:

The "Default font" combo is (mis)placed in the "Widget" tab. I really don't understand why they didn't put it in the "Font" tab.

| improve this answer | |
  • Well, the OP never asked for LXDE-specific instructions. The OP wanted to change the system default serif, sans and mono fonts. Changing LXDE settings will not affect font selection in other applications such as Firefox, Evolution etc. – user237231 Dec 22 '17 at 10:55

To know what default fonts are being used on your system, run the commands

$ fc-match sans-serif
$ fc-match serif
$ fc-match monospace

They should give you the system default sans-serif, serif and monospace fonts respectively.

To set the system defaults to Google's Noto fonts, you need to edit the fontconfig configuration files. For details see the fontconfig documentation. For a readymade config file, see this repo.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.