0

First off, I would like to apologize ahead of time for such a completely absurd accident to happen to my computer. Essentially I wanted to change my Cinnamon-mint theme on linux. But I noticed that the .themes file is hidden. So I decide to change my file authority from execute to read and write, thinking it would make hidden files show themselves. Which is obviously not the case at all.

So basically the highest possible privilege on any file is read and write. Then the ICEauthority error ensued...apparently my computer said I don't have ICEauthority at all, when I actually scripted the code to check if I own it. Because of this, I cannot log into Ubuntu or Cinnamon. And I was so frustrated with being unable to log in, I was preparing to wipe my entire hard drive in the root shell, but I could not do so.... because of my lack of file privileges, that I set prior to scripting a hard disk wipe. The computer basically said that I don't have the authority to execute the "wipe application" unto Ubuntu.So now I'm literally stuck with a braindead operating system. .

Is there any way to change my privileges back to what they used to be? Using the root shell, and then fixing the ICEauthority issue accordingly within the root shell??

0

Under Linux, dot files (files whose name begins with a .) are hidden by the ls command and by many file managers. This is purely a matter of the name, not a matter of permissions.

Don't change permissions of files if you don't understand why or what the consequences are.

For a directory, the “execute” permission means the permission to access files inside this directory. All directories should be executable and readable to their owners, at least.

If you've lost the ability to log in, you can still access your system in two ways.

  • Reboot your computer, press and hold Shift as soon as you see some BIOS messages, until a GRUB menu appears. At that menu, scroll down to the line that says something about “recovery” or “single-user mode” (I don't know what wording Mint uses), and press Enter. If you haven't messed up permissions at the system level, you'll get a shell running as root (the administrator system user), from which you can repair your system.
  • Boot from a Linux live CD/USB and repair the permissions from there. You'll get a much more comfortable user interface this way.

As to what permissions you need to fix and how, that's up to you. You need to fix what you broke. Hopefully you can remember, because I have no idea what you mean by “change my file authority”.

Don't get hung up on “ICEauthority”, it's not the cause of your problem, it may be a symptom. Your problem is the file permissions you changed.

0

Found a solution to the problem!

Thanks for your input. I booted into the GRUB and then went to the Root shell interface as you suggested. From there I tried to repair permissions, but it said that even as an owner, I could only read and write. I went digging around for hours when I read somewhere that the desktop environment called LXDE doesn't deal with ICEauthority issue. I installed it using

# apt-get install LXDE

Rebooted my computer and I noticed it was a desktop environment I could log into. I gave it a shot and like they said, no ICEauthority error.

From there I quickly clicked on the file icon, right clicked on the home folder with my username and recursively changed all of the file settings to Anyone can view and access files, only owner can modify and execute files. ICEauthority has disappeared on my cinnamon and Ubuntu desktop enviroments, and everything is fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.