I booted up Ubuntu and have a background but no panels. Everything else seems to work fine, I can get into terminal and run Firefox for instance. I can create folders on my desktop, etc.

I'm new to Linux so was kind of just guessing to figure out what to do, I tried launching gnome-panel:

$ sudo gnome-panel
gnome-panel: error while loading shared libraries: libcanberra-gtk.so.0: cannot open shared object file: Input/output error

Reinstalling gnome-panel doesn't help. I noticed I get the same error on anything I do:

$ gksudo firefox
    Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk.so.0: cannot open shared object file: Input/output error

Yet Firefox loads. Any ideas? I'm assuming "panel" is the correct word, what I'm talking about is the bar at the top where you can launch applications from.

  • I guess this question should be moved to askubuntu.com. You shouldn't repost it there though, maybe a moderator could migrate it? – rahmu Sep 30 '11 at 23:54

An "Input/Output Error" almost inevitably means your disk needs a fsck (or a hardware error). Check your kernel logs for sda/sdb/sdc/etc. and you will probably find some errors/warnings.

Firefox working because it is loading without the canberra-gtk-module support (libcanberra being used for playing simple sounds), but gnome-panel refuses to even run without it.

I have had a similar effect on a dual-graphics laptop, the menu bar/shortcut bar ran on one GPU while the desktop background/icons ran on the second (unity on ubuntu) and I only saw the latter, but I don't think that is your problem in this case.


“Input/output error” for a file that's stored on a disk usually indicates a hardware error on the disk. Run this (you don't need to be root):

md5sum libcanberra-gtk.so.0

If you get “Input/output error”, look in your kernel logs /var/log/kern.log. You're likely to see a bunch of messages indicating disk errors. I don't know by heart what these messages look like, but they're likely to mention ata and sda.

It's also possible that the cause of the problem is that you're trying to run these programs as root. Most GUI programs are not meant to be run as root. I don't know why you'd get an I/O error though (I would expect something like “no such file or directory”).


So here's what I think you're experiencing: Everything works, except the desktop parts. Basically, no panels, no desktop icons, etc.

I'm not quite sure how to fix the panels, since that would depend on your desktop environment, but for the desktop icons, it's probably Nautilus being a meanie.

Just start Nautilus (nautilus & in a terminal works) and you should see the desktop icons popping back up.

  • Original question seems to indicate an issue reading a library off disk and doesn't mention an issue with icons. Your answer doesn't really address the question. – EightBitTony Oct 20 '12 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.