1

I am having an issue where I will start or restart my PC and suddenly no audio comes from the headphones jack. This only happens occasionally, and I don't know the cause. My PC speakers work fine every time. pavucontrol shows my headphones as plugged-in, with the output db's moving and all, but no output (I've tried multiple headphones and audio sources).

I believe that I have all dependencies for alsa and pulseaudio installed..0

I tried running alsamixer and played with the volume controls, but still no sound. It says my chip is Realtek ALC3232, which has a number of settings that work when I toggle mute and adjust the volume settings for the speakers, although adjusting the headphones section does not have any effect on the headphones output. This is consistent with the pavucontrol interface. I also have an Intel Haswell HDMI card, which does not have any adjustable settings, just S/PDIF, S/PDIF 1 and S/PDIF 2, none of which I can toggle.

Here is some of my system info:

[lucas-pc]/home/lucas$ uname -a
Linux lucas-pc 4.1.2-2-ARCH #1 SMP PREEMPT Wed Jul 15 08:30:32 UTC 2015 x86_64 GNU/Linux
[lucas-pc]/home/lucas$ pacman -Qs alsa
local/alsa-lib 1.0.29-1
    An alternative implementation of Linux sound support
local/alsa-utils 1.0.29-1
    An alternative implementation of Linux sound support
local/zita-alsa-pcmi 0.2.0-2
    The successor of clalsadrv, provides easy access to ALSA PCM devices.
[lucas-pc]/home/lucas$ pacman -Qs pulse
local/libcanberra-pulse 0.30-5
    PulseAudio plugin for libcanberra
local/libpulse 6.0-2
    A featureful, general-purpose sound server (client library)
local/pavucontrol 3.0-1
    A GTK volume control for PulseAudio
local/pulseaudio 6.0-2
    A featureful, general-purpose sound server
[lucas-pc]/home/lucas$

Any suggestions or insight?

  • I have the same chip and exactly those same results. I tried playing with ordering of cards (both the hdmi & normal HD card are handled by snd-hda-intel) but that didn't help either. I would say that because the EQ bands are moving there should be sound - but there's obviously an issue. One line in dmesg seems weird: [ 3815.852263] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input55 which looks like headphone is taken as input – Stan Oct 13 '15 at 10:57
0

So this is not going to be an exact answer but it might help you find out more. I managed to make mine work by using hdajackretask (part of alsa-tools).

I tried a couple of things and this firmware config seems to work:

# cat /lib/firmware/hda-jack-retask.fw 
[codec]
0x10ec0292 0x17aa220c 0

[pincfg]
0x12 0x90a60130
0x13 0x40000000
0x14 0x90170110
0x15 0x0321101f
0x16 0x21211010
0x18 0x411111f0
0x19 0x21a11010
0x1a 0x0321102e
0x1b 0x411111f0
0x1d 0x40738105
0x1e 0x411111f0

[model]
auto

And to make this load on reboot:

# cat /etc/modprobe.d/hda-jack-retask.conf 
# This file was added by the program 'hda-jack-retask'.
# If you want to revert the changes made by this program, you can simply erase this file and reboot your computer.
options snd-hda-intel patch=hda-jack-retask.fw,hda-jack-retask.fw,hda-jack-retask.fw,hda-jack-retask.fw

You will likely need to play around with different configurations. I might have just been lucky...

More information about options is in HD-Audio docs: https://www.kernel.org/doc/Documentation/sound/alsa/HD-Audio.txt

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.