-1

Had a Dropbox install run fine for months on Debian headless server. Had to force reboot server. Now Dropbox will refuse to start without X.

X11 connection rejected because of wrong authentication.

With X it runs just fine and shows icon on Gnome panel.

I need it to run headless again. It's a server that should work "alone", without requiring a remote X display.

For a different user on the same server it runs just fine.

Any idea?

Will it be that it keeps somewhere in the config whether to use X or not?

Thanks,

3

The Dropbox daemon is just checking your $DISPLAY environment variable. If you're not forwarding X over ssh, then $DISPLAY is empty. So, even if you are connected with X Forwarding, you could do:

DISPLAY='' /etc/init.d/dropbox start

or just edit the dropboxd script in the same way.

1

After completely deleting ~/.dropbox ~/.dropbox-dist and ~/Dropbox I reinstalled with dropbox start -i and, apparently, after install it did nothing. dropbox status returned Waiting to be linked to a Dropbox account...

The trick was to run directly .dropbox-dist/dropboxd and it answered with

This computer isn't linked to any Dropbox account...
Please visit https://www.dropbox.com/cli_link_nonce?nonce=xx to link this device.

After authorizing the computer all went fine. Could start and stop without X.

BUT when trying to manually start the daemon

/etc/init.d/dropbox start

it would complain again about not being able to connect to X :-(

The real problem was my root ssh connection had X Forwarding enabled by default and though dropbox would now work fine without X it detected the connection had X and tried to use it.

So the solution has been to remove the X Forwarding for the ssh connection used to manually start the daemon.

0

Dropbox daemon reads configuration settings and tries to reconnect to X like it did before. Delete its configuration for this particular user to make it forget about past and run it again. It will solve your problem.

  • Thanks Tomasz, your answer lead me to the solution but there was another problem. See my own answer. – Toni Homedes i Saun Jul 22 '15 at 9:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.