2

I'm running a dual-booting computer with Windows 7 and Linux Mint installed on it, and I am using a logical NTFS partition that can be accessed both from Linux and Windows.

After having started Windows (and had a system update forced upon me), this partition seems to have lost all its content; in Windows it looks completely empty and in Linux it contains only a $RECYCLE.BIN folder, a System Volume Information folder and a download folder (I had previously removed the first two of these folders, and I suspect that they now have been regenerated by Windows).

However, when I run df -h in Linux, it says that I have only 2.6 GB of free space left on this partition, which is the same amount as before the content went missing.

Running mount reveals that the partition—/dev/sda7—is mounted to /z (which it should be), and running sudo fuser /dev/sda7 to get the PID of the mounting process and ps -e | grep <PID> reveals that the process that is mounting it is mount.ntfs which in turn, indirectly, runs /bin/ntfs-3g (if that is to any help).

I have shut down the computer properly both from Windows and from Linux and not put it in hibernation, so I think the partition should have been properly unmounted from both systems.

Additionally, the download folder was automatically recreated when I started my torrent client, since it is in that folder it by default puts everything it downloads. This folder previously existed and had a lot of content in it, but now it seems to be almost empty except from a new folder that was created for a new download I that started.

So my question is: What has happened, and is there and way to get back the content that went missing?

  • 1
    You need to do CHKDSK or some equivalent in Windows. See this and this and this. – mikeserv Jul 21 '15 at 17:58
  • And to add, If Windows reports it's OK, and no chkdsk is needed add the -f option to Force a check. – eyoung100 Jul 21 '15 at 18:11
  • @mikeserv Thanks, I started the command prompt as administrator and executed chkdsk E: /f (where E: is the name of the partition in Windows), then I could see all the files again. I don't know why though. But it worked. – HelloGoodbye Jul 21 '15 at 19:52
1

Make sure Linux is not in hibernation by turning off the computer when in Linux.

Start Windows. Go to Start->All Programs->Accessories, right-click on Command Prompt and choose "Run as administrator". Run the command chkdsk volume: /f, where volume is the the drive letter.

Make sure to turn off the computer and not put it in hibernation each time you switch from Linux to Windows or vice versa.

This fixed the problem for me.

  • Cool. The best answers are selfies. – mikeserv Jul 21 '15 at 21:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.