5

The Search in Thunar file manager context menu using catfish is present by default as a custom action in Linux Mint Xfce:

enter image description here

The command used is catfish --fileman=thunar --path=%f (also recommended here: http://docs.xfce.org/xfce/thunar/custom-actions).

But in fact it doesn't work.

1
2

In fact a simplified form of that command works:

catfish --path=%f

In Thunar, go to Edit - Configure custom actions, and edit the Search action.

enter image description here

3
  • 2
    You should report this (Question and Answer) as a Bug at the Launchpad Portal for Mint so that it can be properly scripted for all users/
    – eyoung100
    Jul 20 '15 at 18:28
  • 1
    @eyoung100 - bug report: bugs.launchpad.net/linuxmint/+bug/1476358
    – user32012
    Jul 20 '15 at 18:41
  • --path defines a default search path and this usage is wrong! Check answer from @vdicarlo.
    – 71GA
    Jan 11 at 9:21
1

I know it's over a year ago, but I just wanted to add to the answer by cipricus. You need to go to the tab "Appearance Conditions" (next to the "Basic" tab) and put a tick in the boxes for the file types you want. Then catfish works.

And yes, it's fast!

Regards

1

While catfish --path=%f did not work for me, catfish %f did.

2
  • 1
    Thank you! This is working on Debian 10! catfish --path=%f did not work. Actually, in man catfish parameter --path is described as "default search path". Do we want to always chabnge the default? No! We do not! Manual itself defines this usage: catfish [options] path query so the path is allready there and we should not use the --path parameter to change "default search path" but instead use the program as @vdicarlo pointed out.
    – 71GA
    Jan 11 at 9:04
  • 1
    I changed my mind and use it like this now: catfish --path=~ %f. It is nice to have a constant default search path in case anything fails.
    – 71GA
    Jan 11 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy