1

When I try to mount my 1tb hard drive /dev/sda I get

"exited with non-zero exit status 21: ntfs-3g-mount: mount failed: Device or resource busy"

I have tried using the

"sudo mount -t ntfs-3g -o uid=matt,gid=users,umask=0022 /dev/sda2 /mnt/a/" 

command for this and the GUI file manager Dolphin.

lsblk output:

sda                   8:0    0 931.5G  0 disk   
├─sda1                8:1    0   100M  0 part   
├─sda2                8:2    0 931.4G  0 part   
└─pdc_cfffhahgfg    253:3    0 931.3G  0 dmraid 
  └─pdc_cfffhahgfg1 253:4    0   100M  0 part   
sdb                   8:16   0 111.8G  0 disk   
├─sdb1                8:17   0   500M  0 part   /boot
└─sdb2                8:18   0 111.3G  0 part   
  ├─fedora-swap     253:0    0   7.8G  0 lvm    [SWAP]
  ├─fedora-root     253:1    0    50G  0 lvm    /
  └─fedora-home     253:2    0  53.6G  0 lvm    /home

The df command does not even show the drive / partition(s).

I am on Fedora linux 22. 4.0.8-300.fc22.x86_64 #1 SMP Fri Jul 10 21:04:56 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Thank you very much for your help.

1
  1. Are you using a cluster environment? If yes, please check if the device has been using by another node.
  2. Also please make sure /dev/sda2 has a correct format.
  3. The "df" command only shows which are already mounted.
  • 1. No. I am on a home computer. 2. How would I do this? 3. Sorry. Didn't know. – Matt Jul 20 '15 at 7:26
  • If you're a home user, that'll be pretty easy, attach your device to a windows PC, see if it can mount and access properly. – NeilWang Jul 20 '15 at 8:03
  • Any other way to do this? I don't currently have a working windows system. I had Windows installed before installing Fedora (just installed) and the drive had worked up to that point. It was a secondary drive btw / not the boot drive. Thank! – Matt Jul 20 '15 at 8:15
  • You may tried to use this command to check if the partition is ok: ntfs-3g.probe --readwrite /dev/sda2 – NeilWang Jul 20 '15 at 9:08
  • I get no output on doing that command. I had to remove the last - for some reason. – Matt Jul 20 '15 at 17:30
0

I have fixed the drive. All I had to do was check the partition with a partition editor and it fixed it. Hopefully this will help others with the same problem.

0

I was getting this error when I tried to use a drive that was once in a linux software raid array. Even though I removed the existing partition and created a new one with type 7 (NTFS) it kept thinking the drive was part of a raid array. The linux raid signature remained on the disk.

I used the wipefs utility...

sudo wipefs --all --force /dev/sdc

... then recreated the partition, formatted, rebooted, and mounted.

For more info see...

https://www.cyberciti.biz/faq/howto-use-wipefs-to-wipe-a-signature-from-disk-on-linux/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.