8

I am using Centos 6.6 (x86_64) Trying to install most stable mongodb version available. but I am stuck with this error (which might seem repeated but none of the previous answers worked for me)

[root@localhost home]# sudo yum install -y mongodb-org
Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: ftp.iitm.ac.in
 * extras: ftp.iitm.ac.in
 * updates: centos.01link.hk
http://repo.mongodb.org/yum/redhat/%24releaserver/mongodb-org/3.0/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: mongodb-org-3.0. Please verify its path and try again

My repo:

vim /etc/yum.repos.d/mongodb-org-3.0.repo

[mongodb-org-3.0]
name=MongoDB Repository
baseurl=https://repo.mongodb.org/yum/redhat/$releaserver/mongodb-org/3.0/x86_64/
gpgcheck=0
enabled=1

tried

yum clean all
yum check
yum erase apf
yum erase upgrade 

also tried

sudo sed -i 's/https/http/g' /etc/yum.repos.d/mongodb-org-3.0.repo

my yum.conf

[root@localhost home]# cat /etc/yum.conf
[main]
cachedir=/var/cache/yum/$basearch/$releasever
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
installonly_limit=5
bugtracker_url=http://bugs.centos.org/set_project.php?project_id=19&ref=http://bugs.centos.org/bug_report_page.php?category=yum
distroverpkg=centos-release

#  This is the default, if you make this bigger yum won't see if the metadata
# is newer on the remote and so you'll "gain" the bandwidth of not having to
# download the new metadata and "pay" for it by yum not having correct
# information.
#  It is esp. important, to have correct metadata, for distributions like
# Fedora which don't keep old packages around. If you don't like this checking
# interupting your command line usage, it's much better to have something
# manually check the metadata once an hour (yum-updatesd will do this).
# metadata_expire=90m

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d
[root@localhost home]# 

Please help me figure this out !

also i have set SELinux=permissive After fixing errors which sim pointed i am getting the following error

[root@localhost Hubatrix]# yum clean all
Loaded plugins: fastestmirror, refresh-packagekit, security
Cleaning repos: base extras mongodb-org-3.0 updates
Cleaning up Everything
Cleaning up list of fastest mirrors
[root@localhost Hubatrix]# cat /etc/yum.repos.d/mongodb-org-3.0.repo
[mongodb-org-3.0]
name=MongoDB Repository 
baseurl=https://repo.mongodb.org/yum/redhat/$releasever/mongodb-org/3.0/x86_64/repodata/repomd.xml
gpgcheck=0
enabled=1

[root@localhost Hubatrix]# sudo yum install -y mongodb-org
Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Install Process
Determining fastest mirrors
 * base: centos.excellmedia.net
 * extras: centos.excellmedia.net
 * updates: centos.excellmedia.net
base                                                                                                                          | 3.7 kB     00:00     
base/primary_db                                                                                                               | 4.6 MB     01:21     
extras                                                                                                                        | 3.4 kB     00:00     
extras/primary_db                                                                                                             |  31 kB     00:00     
https://repo.mongodb.org/yum/redhat/6/mongodb-org/3.0/x86_64/repodata/repomd.xml/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: mongodb-org-3.0. Please verify its path and try again
3

The error is pretty clear from yum:

http://repo.mongodb.org/yum/redhat/%24releaserver/mongodb-org/3.0/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"

There isn't a file at the other end of that URL for yum to download, hence the 404. Put that URL in your browser and start to navigate to see what files are actually there.

This is the correct URL when I browse their repo:

I suspect they moved things but didn't regenerate the repomd.xml file. You can work around the issue by downloading the packages manually and then using yum install .. to install things.

Typo

But I think there's a typo in your repo file:

baseurl=https://repo.mongodb.org/yum/redhat/$releaserver/mongodb-org/3.0/x86_64/

Should be this:

baseurl=https://repo.mongodb.org/yum/redhat/$releasever/mongodb-org/3.0/x86_64/

  • hello sim thanks for the reply but after I solved those typos and changed to repmod.xml i till get this error. please check the edit of my question @sim – hubatrix Jul 20 '15 at 6:47
  • @Brewmaster - please check that URL. It's still incorrect. You now have /repodata/repomd.xml repeated 2 times! – slm Jul 20 '15 at 12:43
  • @slm: FWIW, yum localinstall is deprecated since quite some time, simply use yum install as usual. From the man page: localinstall rpmfile1 [rpmfile2] [...] (maintained for legacy reasons only - use install) – doktor5000 Jul 20 '15 at 17:46
  • @doktor5000 - thanks, hadn't noticed that in the man pages. Says that it'll be maintained for legacy reasons there, so should be OK to use never the less, but will stop telling ppl to use it 8-). BTW, fixed the post. – slm Jul 20 '15 at 17:48
  • 1
    @Cmag - this is the correct url: repo.mongodb.org/yum/redhat/6/mongodb-org/3.0/x86_64/repodata/… – slm Jan 11 '16 at 21:49
3

It happens if your repo configurations are dirty.

Try this

sudo rm -rf /etc/yum.repos.d/mongod*
sudo yum clean all

Then create repo again

sudo vi /etc/yum.repos.d/mongodb-org-3.4.repo

Then paste

[mongodb-org-3.4]
name=MongoDB Repository
baseurl=https://repo.mongodb.org/yum/amazon/2013.03/mongodb-org/3.4/x86_64/
gpgcheck=1
enabled=1
gpgkey=https://www.mongodb.org/static/pgp/server-3.4.asc
sudo yum install -y mongodb-org
0

I resolved this issue by removing the /$releaserver and replaced 7Server in the link http://repo.mongodb.org/yum/redhat/$releasever/mongodb-org/3.0/x86_64/ so try to replace that link with this change.

-1

Cleaning the cache worked for me:

sudo yum clean all

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.