5

I am trying to use syndaemon to disable my touchpad while I type. I know that the GUI for this doesn't work for many people but all the posts I've seen online suggest that using syndaemon from the command line should work. It doesn't work for me, however.

To test whether the touchpad is off while I type, I type with one hand while moving the mouse and clicking with the other. I've also tried turning on palm detection, which I test just by typing for a while and seeing if I get a touchpad click (I always do, pretty promptly).

Linux Mint 17.2 Rafaela (installed it yesterday)

Dell Inspiron 11 3000 series

  • Output of xinput list:

    > xinput list
    ⎡ Virtual core pointer                      id=2    [master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
    ⎜   ↳ DLL064D:00 06CB:2985                      id=12   [slave  pointer  (2)]
    ⎜   ↳ SynPS/2 Synaptics TouchPad                id=14   [slave  pointer  (2)]
    ⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
        ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
        ↳ Power Button                              id=6    [slave  keyboard (3)]
        ↳ Video Bus                                 id=7    [slave  keyboard (3)]
        ↳ Video Bus                                 id=8    [slave  keyboard (3)]
        ↳ Power Button                              id=9    [slave  keyboard (3)]
        ↳ Sleep Button                              id=10   [slave  keyboard (3)]
        ↳ Integrated_Webcam_HD                      id=11   [slave  keyboard (3)]
        ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]
        ↳ Dell WMI hotkeys                          id=15   [slave  keyboard (3)]
    

What I've tried so far:

  • Control Center -> Mouse -> disable touchpad while typing: no effect

  • gpointing-device-settings: shows two touchpads:

    • DLL0446:00 06CB:2985: enable palm detection -> no effect; when I disable this touchpad, my touchpad becomes unresponsive

    • SynPS/2 Synaptics Touchpad: disabled (turning it on and modifying settings seems to have no effect)

  • syndaemon: killall syndaemon; syndaemon -i 10 -K -d: no effect (also tried with -R). ps aux | egrep syndaemon shows that no other syndaemon processes are running. I have tried this with and without the "disable touchpad while typing" checkbox set in Mouse Preferences.

  • synclient: synclient PalmDetect=1 PalmMinWidth=10 PalmMinZ=200: no effect

I am at my wit's end. The solutions attempted above seem to work for everyone else! Why can't I get syndaemon to work for me?

  • Not familiar with syndaemon myself, but does this existing question/answer offer any inspiration? Touchpad issue: jumping cursor while typing (Ubuntu 14.04), syndaemon don't help – steve Jul 19 '15 at 20:28
  • Interesting but didn't solve my problem. I have the most recent kernel -- did try installing linux-image-extras and rebooting but no joy. Seems like with my recent kernel it is not indicated to install the patch. Sadness. Thank you though! – Jessica Hekman Jul 20 '15 at 0:21
  • My current theory is that the root of the problem is the two entries I see for two different touchpads in xinput (see above) and in gpointing-device-settings. I suspect that syndaemon is talking to the "SynPS/2 Synaptics Touchpad" which is actually not connected to any real device, and not talking to the actual touchpad at DLL064D:00 06CB:2985. But how do I tell it to talk to the correct touchpad? – Jessica Hekman Jul 21 '15 at 16:17
  • I don't have the answer yet but the issue seems to be related to the which device syndaemon is disabling. In my case the xinput output for the mouse/touchpad is the same but when I disable the synaptic touchpad the touchpad remains active. When I disable the #12 device 06CB:2985 the touchpad is disabled. So what I think is happening is that syndaemon is disabling device 14 (as it should since its the synaptic touchpad) but the touchpad is actually on device 12. – user142135 Nov 7 '15 at 16:54
  • I agree, from what I can tell that's exactly the problem. I'd hoped to figure out a way to tell syndaemon which device it should disable, but I can't seem to figure that out. – Jessica Hekman Nov 7 '15 at 22:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.