1

A customer of mine wants to use gmail as their default mail client but I have rolled forward to a new CENTOS server version (6.6, ok it's not "new" new) and the dovecot and postfix settings are default to be fairly hardened.

However though the centos server supports IMAP SSL out of the box, I cannot use that because gmail (as a client) only supports POP3 and with PLAINTEXT authentication.

gmail said

POP3 Server denied POP3 access for the given username and password.
Server returned error: "Plaintext authentication disallowed on non-secure
(SSL/TLS) connections."

I followed this tutorial but the changes I made have not effect I still get that gmail error message. Port 110 is open.

As per the howto:

/etc/dovecot/conf.d/10-master.conf is set to

unix_listener /var/spool/postfix/private/auth {
   mode = 0666
   user = postfix
   group = postfix
}

I added these lines to /etc/postfix.main.cf

smtpd_sasl_type = dovecot
smtpd_sasl_path = private/auth
smtpd_sasl_auth_enable = yes
smtpd_recipient_restrictions =
  permit_sasl_authenticated
  permit_mynetworks
  reject_unauth_destination

extra info

 [root@somemail ~]# postconf -d | grep mail_version
 mail_version = 2.6.6
 milter_macro_v = $mail_name $mail_version
 [root@somemail ~]# dovecot --version
 2.0.9
 [root@somemail ~]# cat /etc/centos-release
 CentOS release 6.6 (Final)

but at the moment I still get the gmail warning, what else should I be doing to enable plaintext authentication?

  • 1
    I figured it out there needs to be the line disable_plaintext_auth = no in /etc/dovecot/dovecot.conf – Mr Heelis Jul 19 '15 at 14:00
1

Run this command:

$ doveconf disable_plaintext_auth
2

Add disable_plaintext_auth = no in the dovecot configuration file. Open /etc/dovecot/dovecot.conf and add following line at the end of the file:

disable_plaintext_auth = no

Finally restart dovecot service by following command:

service dovecot restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.