1

It was the first time I encoded a video on Ubuntu. I used ffmpeg to extract the video/audio, encode them and join with a subtitle to a new file.

All these steps were fine. I used the following command to mux these files.

$ ffmpeg -i [video_file] -i [audio_file] -i [sub_file] \
   -c:v copy -c:a copy -c:s mov_text \
   -metadata:s:a language=eng \
   -metadata:s:s language:por \
   -sub_charenc UTF-8 [output_file]

However, Miro player doesn't recognize the subtitle. Even that, when I play other files with Miro, it finds the subtitles just fine. This makes me think that I'm possibly missing something in the above command.

Another strange thing is playing this new file with VLC and other players on Ubuntu/Windows, I can turn on the subtitles just fine.

Can anyone help me out with this?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.