I have a problem on my notebook (MSI E-620) running Ubuntu Natty Narwhal x86. When I installed it there was just output, when I plugged my headphones in. The speakers in my notebook do not play anything. I tried a lot - now I don't have a listed sound device in Audio-Settings.

The following error appears every time I try to install alsa-driver:

root@andre-EX620:/home/andre/Downloads/alsa-src/alsa-driver-1.0.8# ./configure 
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be included... yes
checking whether gcc needs -traditional... no
checking for current directory... /home/andre/Downloads/alsa-src/alsa-driver-1.0.8
checking cross compile... 
checking for directory with kernel source... /lib/modules/2.6.38-11-generic/build
checking for directory with kernel build... 
checking for kernel version... 0.0.0
checking for GCC version... ./configure: eval: line 3547: syntax error near unexpected token `)'
./configure: eval: line 3547: `my_compiler_version=4.5.2-8ubuntu4)'

But the Audio-devices are there..

root@andre-EX620:/home/andre/Downloads/alsa-src/alsa-driver-1.0.8# lspci | grep -i Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
06:00.1 Audio device: ATI Technologies Inc RV620 Audio device [Radeon HD 34xx Series]

Any suggestions?


I solved the problem by executing the following lines:

su root
vi /etc/modprobe.d/alsa-base.conf #Am Ende 'options snd-hda-intel model=3stack-6ch-dig', bzw. eine Option von hier einfügen: http://wiki.ubuntuusers.de/Soundkarten_konfigurieren/HDA?redirect=no#Beispielkonfigurationeneinfügen

add-apt-repository ppa:ubuntu-audio-dev/ppa
apt-get update
apt-get install linux-alsa-driver-modules-$(uname -r)
restart -r now

I don't know if recompiling the driver is the best way for you to get sound, but I think I can get you past the error in configure. The script was clearly not tested with “exotic” version strings. It would be worth notifying the authors of this issue. The problematic line is

eval $versionvar="$ac_compiler_version"

What's going on here is that eval is evaluating a string composed of the variable name, an equal sign and the string to assign. This is wrong: it should be evaluating a string composed of the variable name, an equal sign and a shell fragment to generate the string to assign. In other words, the quoting is wrong. This is the right way to do it:

eval $versionvar=\"\$ac_compiler_version\"

The same fix should be applied to all the uses of eval in configure.in.


Try the following:

  • append the following line in the file /etc/modprobe.d/alsa-base.conf

    options snd_hda_intel model = STAC9227
  • reload alsa

    2.alsa force-reload
  • play a song

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.