3

I installed CrunchBang++ on a VirtualBox machine. I installed a few packages from the welcome script and the VirtualBox guest additions. I then installed i3 and set it as my window manager by creating ~/.xsession with

exec /usr/bin/i3

as contents.

Everything works as intended with one exception: When I scroll up or down on the mouse wheel, while simultaneously moving the mouse vertically, the current workspace is changed. I'm not sure if X, SLiM and i3 or any other process is causing this. What is the cause of this problem and how do I stop it?.

2 Answers 2

2

This is not an answer but a suggestion on how you might find the answer.

Try running xev, You should be able to confirm that scrolling up/down in the xev window produces logs with mouse button 4 and 5 e.g.:

ButtonRelease event, serial 46, synthetic NO, window 0x4000001,
    root 0xc4, subw 0x0, time 169151426, (78,60), root:(142,831),
    state 0x800, button 4, same_screen YES

ButtonPress event, serial 46, synthetic NO, window 0x4000001,
    root 0xc4, subw 0x0, time 169151506, (78,60), root:(142,831),
    state 0x0, button 5, same_screen YES

If its not it, it might be an X configuration problem, i.e. your mouse scroll inputs are somehow mapped to some other key events. But I think the first place to look would be in the i3 configuration. I assume the desktop switching behavior would be a feature and therefor there might be an option where it is bound to a key(s) in the configuration.

Basically; figure out what events mouse scrolls are producing, then grep configs for them.

1

As this post from Arch Linux Forums suggested, the problem was with VirtualBox rather than any other component. Simply disabling automatic mouse integration fixed the problem.

I'm not sure exactly why this is causing problems. An even better answer would of course be one that solves this without disabling automatic mouse integration.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .