1

I just noticed I have some kind of graphics artifacts which effect visual discomfort like so called "blurry"; And, moreover, I am not sure I have correct DPI settings right now (give me advise concerning DPI too pls)... I detected artifacts by taking screen by my mobile phone 60hz cam (see image)

enter image description here

...so, as I can get it, I need some graphics acceleration or i915 module fix or...?

EDIT : I have uxa acceleration mode right now cause visually it seems more clear ... the /etc/X11/xorg.conf.d/20-intel.conf content is :

Section "Device"
    Identifier "Intel Graphics" #or card0
    Driver "Intel"
    Option "AccelMethod" "uxa" #sna or uxa  
    Option      "Backlight"    "intel_backlight"
    BusID       "PCI:0:2:0" 
EndSection

EDIT : I just tried to install linux-mainline-baytrail 4.0rc4-1 and that's what I have in output :

linux-mainline-baytrail 4.0rc4-1  (Tue Mar 17 20:33:28 CDT 2015)
( Unsupported package: Potentially dangerous ! )
==> WARNING: This PKGBUILD describes a splitted package.
==> Specific package options are unknown
==> linux-mainline-baytrail dependencies:
 - docbook-xsl (already installed)
 - kmod (already installed)
 - inetutils (already installed)
 - bc (already installed)
 - xmlto (package found)

seems like kernel-3.16.7 already has something related to bay trail support or I don't know?


So my question is... how to analyse what causes the blurry effect, how to check if dpi is correct and how to fix the graphics artifacts?

Thanks

p.s.

  • kernel-3.16.7
  • os: linux arch x64
  • video card : Intel HD Graphics (Bay Trail)
  • You said, you have Arch? Did you put i915 into MODULES in /etc/mkinitcpio.conf? Like it says here – Alko Jul 17 '15 at 10:21
  • The lsmod outputs I have i915 module init-ed – user390525 Jul 17 '15 at 14:20
  • But I don't have intel_agp module in lsmod list; Does it required or not? – user390525 Jul 17 '15 at 14:27
  • and I am not sure what the instruction says "If you are using a custom EDID file, you should embed it into initramfs as well: " ? – user390525 Jul 17 '15 at 14:45
  • How to get EDID file ? I tried read-edid util but get-edid outputs nothing :( – user390525 Jul 19 '15 at 6:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.