1

One of the features that I heavily use in XFCE is grabbing a window with Alt (Alt + click and drag) and then changing to a different workspace (which I bound to Alt+number). The net effect is moving the grabbed window to the new workspace and place it all in the same keystroke. I find it to be a very intuitive and more effective than clumsy "move window to workspace" bindings.

However, this feature is no longer working, and I'm not quite sure how to fix it.

I'm running some flavor of RHEL6 that came with a Gnome session. I cleanly installed XFCE4 (except for xfce4-session, which I excluded due to a conflict), logged out, and logged back in using the GUI session selector. After rebinding the default workspace switch keys, everything worked as it should; I was able to grab windows and switch workspaces without a problem.

After rebooting, I logged in with XFCE4 to start, and I could no longer switch workspaces while grabbing windows.

If a window is being grabbed, most of the bindings don't work or even make it through to xev (change workspace, etc). However, arrow keys (to nudge) and ESC (to cancel) do work, and they are defined in the same place as the change workspace bindings (in Window Manager Settings). Also, clicking and holding the mouse button on an empty spot on the desktop allows the workspace switch bindings to work.

I've tried changing the binding to something else, and even to a single key. Still didn't work.

I also tried installing xbindkeys and manually defining a workspace switch binding, but it too suffers from the same issue of not working while a window is being grabbed. It doesn't matter if I grab the title bar or hold down Alt and click anywhere on the window.

Any further debug/advice for going about this problem?

2
+25

You need xfce4-session, or else your desktop will not run properly (yes, I'm serious).

Are you running xfwm4? Do you have a saved session? Is xfsettingsd running?

Oh, and don't use Xfce4.8 anymore. It's horrible outdated and does things the wrong way (like thunar-vfs).

  • I have since installed xfce4-session and rebooted. No dice. I am running xfwm4, xfsettingsd, and no saved sessions. I am, however, using 4.8, as that is the version in our blessed repos. – user103160 Jul 22 '15 at 15:25
  • You can try your luck in webchat.freenode.net/xfce, where help can be given in a much more interactive way. – killermoehre Jul 22 '15 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy