3

I have pre-installed windows 8.1 on my machine and its a uefi enabled machine. I installed linux mint 17.1 on this by the side of windows 8.1.

As I was unaware about the approach to install linux mint in a dual boot on uefi system, I installed it in a way I used to install linux mint in non uefi system.

After this I was unable to boot my windows but only linux mint. After reading many post on this site I got to know that boot-repair can fix the problem. I boot-repaired the system, by doing this I was able to see windows in boot menu but when I tried to boot it the screen gone black after colorful cross lines.

[ -d /sys/firmware/efi ] && echo "Installed in UEFI mode" || echo "Installed in Legacy mode" The execution of the above command gives Installed in Legacy mode.

and boot-repair Advanced Options shows something like this:

enter image description here

How do I convert linux mint to uefi from legacy mode and be able boot windows 8.1 again with linux mint 17.1

  • To me it sounds like you changed the boot mode to legacy in the bios of your machine. A Windows installation that was installed in uefi mode won't boot in legacy mode. You will have to switch back to uefi mode in your bios and then try to get your linux back to work. The easiest solution may be to reinstall linux mint in uefi mode. – Thawn Jan 5 '16 at 12:58
  • Hi @Thawn thanks for your comment, I haven't changed anything in my bios setting, however after facing this problem I once tried to find the way to do this but was unable to find that option to change boot mode. before installing Linux mint I had only changed boot order to usb disk. Cannot I boot windows by changing boot mode to efi from bios and vice versa to boot linux mint? – Sagar Guhe Jan 5 '16 at 13:06
  • Hi, I found this page with an extensive guide on how to install older Ubuntu versions dual boot with windows 8. Maybe you find useful help there. – Thawn Jan 5 '16 at 14:17
  • However, it may be much easier to reinstall linux mint in uefi mode rather than trying to fix it. – Thawn Jan 5 '16 at 14:20
  • Actually linux mint is installed on my workplace pc so I cannot reinstall it and spend that much time on it.. – Sagar Guhe Jan 5 '16 at 14:35
0

You say that you've installed it in the way that you would with a non-UEFI system. That probably means you've enabled CSM/Legacy Boot and/or disabled Secure Boot.

Sometimes Windows will boot in such a configuration; other times it will not. I'd advise you to turn UEFI back on, along with Secure Boot just to be sure.

Not 100% Relevant, But Noteworthy:

I have a similar situation with an old Vista laptop with XP also installed. XP will only boot in a particular drive mode set in the BIOS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.