2

I am currently using Linux Mint 17.2 Cinnamon 64-bit on my laptop with hybrid graphics (Intel/AMD) and I can't get the AMD proprietary graphics drivers (fglrx) running properly. They always put my system in an unusable state. I also tried other distributions (Ubuntu 14.04, Ubuntu 15.04, openSuse, CentOS, ElementaryOS) and get similar errors.

The problem is: On a fresh install, i do all system updates. Then I install fglrx via the drivers tool that comes preinstalled. I select fglrx, apply the changes and reboot. When the system boots up, I can see the plymouth splash, then a black screen that shows "login" for a short period (I guess thats where the auto login happens). After that a whole bunch of text comes up and it says "fixing recursive fault but reboot is needed". At that moment I press CTRL+ALT+DEL and the system reboots and shows me "fixing recursive fault but reboot is needed" again. I repeated that process a couple of times and finaly the desktop showed up. I do "amdconfig --initial" and reboot. Again the recursive faults... but this time I gave up after >10 reboots not working.

What am I doing wrong? Do I have to install some additional packages/dependencies? Has anyone experienced similar behavior? Any help is appreciated. Btw it worked perfectly fine on MS Windows, so the hardware doesn't seem to be broken.

Specs

  • Lenovo G510 laptop
  • Intel Core i7-4700MQ
  • Intel HD Graphics 4600
  • AMD Radeon HD 8750M

uname -r

3.16.0-38-generic

lspci

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor DRAM Controller (rev 06)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
00:1c.1 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #2 (rev d5)
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM86 Express LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 05)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Mars [Radeon HD 8670A/8670M/8750M] (rev ff)
08:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)
09:00.0 Ethernet controller: Qualcomm Atheros QCA8172 Fast Ethernet (rev 10)
  • You have a hybrid AMD Graphics System. The Intel HD Graphics 4600 Computes and Renders. The AMD Radeon HD 8750M only renders, therefore you must use the Intel Based Card to compute, and then send the output to the AMD Based Card. See HybridGraphics, and this AskUbuntu post. – eyoung100 Jul 16 '15 at 21:53
  • Thank you for trying to help. Of course I have hybrid graphics and I know how they work. Sorry if it wasn't clear enough in my post, I'll edit it. The first link you sent me suggests to install fglrx, nothing else. That's what I'm having problems with. I don't know what to make of the second link. Should I try the "nomodeset"? I dont want to wreck my system again... – user3563584 Jul 17 '15 at 16:17
1

Problem

Hybrid Graphics Systems require two graphics drivers. Your issue is that you are trying to use only one driver to "drive" two totally different cards. On the Kernel Level this is done with the vga-switcharoo kernel setting, which is enabled on major distributions by default. The issue is further compounded by the fact that the switcharoo option isn't smart, ie. the kernel knows what the cards are attempting to do, but with improperly configured userspace tools, the kernel can't decode the proper option

Solution - Part 1

In order to get to a properly working Desktop, I'm assuming that nothing works properly. In order to fix this, readers can:

  1. Press Ctrl + Alt + F3. This should display a Text-Mode TTY.
  2. Login using your credentials.
  3. Assuming your using Cinnamon, with default settings, issue a sudo service mdm stop to temporarily disable the Cinnamon Desktop.
  4. Test for Internet Connectivity by issuing sudo ping -c4 www.mint.org.
  5. Uninstall all FRGLX drivers, by issuing sudo apt-get purge frglx*
  6. Remove the XOrg.conf File: sudo rm -v /etc/X11/xorg.conf
  7. Reinstall the Intel XOrg Driver: sudo apt-get install --reinstall xserver-xorg-video-intel
  8. Reinstall XOrg: sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:amd64
  9. Reconfigure XOrg: sudo dpkg-reconfigure xserver-xorg
  10. Restart the XOrg Server: sudo service mdm start

Solution - Part 2

Method 1 - The Mint Way: Try this First. In your now running desktop, click the Mint Menu. In the Search Box, type D + R + I + V. An Entry for Driver Manager should appear. Select it, and let it scan the system for 3rd party hardware. In the list will be the version of frglx in the Mint Repositories. This does not install Control Center. See Final Steps.

Use the Answers outlined here, involving amdconfig to properly switch cards, until you complete Final Steps.

Method 2 - Directly from AMD: This should be a last resort, therefore use with caution. I say this because these packages may not be the versions in the official Mint repositories. Visit the AMD Catalyst™ Driver for Linux Download Page. Download:

  • AMD Catalyst™ 15.7 Proprietary Ubuntu 14.04 x86_64 Video Driver for Graphics Accelerators
  • AMD Catalyst™ 15.7 Proprietary Ubuntu 14.04 x86_64 Catalyst Control Center

Don't be alarmed that the Downloads say Ubuntu, as Mint is a fork of Ubuntu LTS. Issue a sudo dpkg -i fglrx* from a terminal in the directory where the downloads are saved. If warned to use the --force option, don't, or you may end up having to restart at Part 1.


Final Steps

After completing either method, install fglrx-pxpress with sudo apt-get install fglrx-pxpress and reboot. After reboot issue inxi -G, which should report your ATI Card is now active. If you used method one, you should now install Catalyst Control Center. Issue sudo apt-get install fglrx-amdcccle. Doing so ensures that the driver you installed in the driver Manager matches the Control Center Version.

Reboot once more, and upon returning to desktop, issue sudo amdcccle to Start Control Center. Choose Integrated from the Graphics Card Settings, and test.


Caveats

  1. You cannot use the Catalyst Control Center to "switch cards," as using full Intel disables the RadeonHD, and using full RadeonHD disables the Intel HD, which will crash the XOrg server. When updating, you must use the Driver Manager to update the frglx driver, because Integrated must be used at all times. Installing the frglx drivers from the command line assumes that the ATI Card is the only GPU on the system. See the answer I linked above, specifically item 4.
  2. In order for XOrg to behave properly, it must always be started with the Intel Based Driver. This will be done automatically, once the Control Center is set to Integrated.
  3. After being properly setup, readers can choose card usage based on the application, i.e. if you're using a game you tell the Control Center in its per Application Setting to turn on the Discrete Card only. In this way, all computations are done by the IntelHD Card and then the result is offloaded to the RadeonHD Card for rendering.

References

Ask Ubuntu - Intel/AMD Hybrid graphics on Ubuntu 14.04
How to Stop the Graphical User Interface on Ubuntu and Linux Mint
How to Properly Remove the Proprietary ATI Drivers on Debian, Ubuntu and Linux Mint
How do I install a .deb file via the command line?
Mint Forums - Installing AMD/Intel Hybrid Graphic System Drivers in Mint 16

  • Thank you! That's a very thorough answer. I have a few qustions though: vga-switcharoo seems to be only for muxed graphics. My hardware is muxless as far as I know. I installed fglrx via driver manager and it installes the ccc automatically. fglrx-pxpress is not required according to wiki.ubuntu.com/X/Config/HybridGraphics – user3563584 Jul 18 '15 at 12:56
  • vga-switcharoo is used in both cases. Turning on the Discrete Card/Off the integrated and vice versa is done via the vga-switcharoo option because the only difference between muxed, and muxless is the power saving option. See this Redit Post from some haters, and this WikiPedia Entry on ATI Support – eyoung100 Jul 19 '15 at 1:28
0

I was having the same problem with AMD Intel and Linux Mint 17.3. I updated my kernel to 4.x and now I am using xserver-xorg-video-ati (recommended, open source) with no such problems. fglrx was giving problems for me: I was not able to use hardware acceleration in chrome. So, updating kernel might be a solution worth trying

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.