2

I'm writing a python 3.4 app on a centos box. Normally, when I have to reset my tmux session, such as after a reboot I do the following:

[zippy@localhost ~]$ scl enable rh-python34 httpd24 bash
[zippy@localhost ~]$ source python34/bin/activate
(python34)[zippy@localhost ~]$

I could do it in one command, but I lose my prompt, and therefore presumably other stuff.

[zippy@localhost ~]$ scl enable rh-python34 httpd24 "source ../python34/bin/activate && bash"
(python34)

I'm actually not sure why I can't just enter the virtual environment without enabling scl, but it still try to execute the default python instead of the scl one that I created the virtual environment with.

-1
scl enable rh-python34 httpd24 -- bash --rcfile <(echo '. ~/python34/bin/activate')

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.