1

I have two mesh nodes that I have configured to be on a mesh created using OpenWrt. I used the tutorial here to set that up. When I ran iw dev $MESH_IFACE station dump, I got the output that I expected which confirmed that the wireless client node was connecting to the mesh.

So, I tried to ping the client node from the access point (which is not wireless), but it said that there was no route to host. When I ran iw dev $MESH_IFACE mpath dump to see the path between the two nodes, nothing showed up.

I thought, maybe I need to create a wireless bridge in order to create a path between the two and send traffic across the network? I followed the tutorial here called Atheros and MAC80211 WDS to implement a wireless network bridge (wireless repeater): http://wiki.openwrt.org/doc/recipes/atheroswds

After following that tutorial and enabling WDS, the iw dev $MESH_IFACE station dump output disappeared. Nothing happened at all, and there was still no path between the two nodes.

Can anyone point me in the right direction tutorial wise or let me know why enabling the wireless network bridge would not help me ping between the two nodes?

I'm fairly new to this so I'm open to conceptual or technical answers. Thanks for any help in advance.

0

Have you tried adding the mesh interface to the br-lan bridge of OpenWRT? I can't give you an command for the CLI, but if I checkbox the mesh interface in the web gui to be part of the lan bridge, it works.

0

You may find the answer by following this link:

https://forum.openwrt.org/viewtopic.php?id=59900

1
  • Welcome to stackexchange. Your answer is just a link; here's a quote from the help center, which I recommend reading through: "Links to external resources are encouraged, but please add context around the link so your fellow users will have some idea what it is and why it’s there. Always quote the most relevant part of an important link, in case the target site is unreachable or goes permanently offline." unix.stackexchange.com/help/how-to-answer
    – Wildcard
    Nov 6 '15 at 2:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.