0

I am running Kali 1.1 on Parallels 9 for Mac and am having some issues.

Firstly, the WiFi doesn't work (normal for use within a virtual machine, but also isn't working with my external wireless card with confirmed functioning chipset. I am hoping the second issue's solution will solve this one too.

Parallel Tools - I tried three or four different ways (from a virtual disc, copied to the Kali environment from the virtual disc [as it didn't have execute permissions on the disk itself], and also follwing several threads from forums - listed below). All of these attempts resulted in the an error message: "An error occurred whn downloading required components for Parallels Tools installation. -Kernel sources Install these components and try again"

I don't have any clues as to what sources may be missing.

Any other ideas about how this might be solved? Anyone already done it?? I can't find anything else. Another thing I tried was to boot Kali from a USB drive (dual booting, not through virtually with Parallels), which took a long time as one must 'copy' the .iso file to the USB stick with the 'dd' funtion. This however also didn't work. It actually didn't even make it into Kali, it froze while still at the dual boot screen, subsequently blowing out my USB port, requiring a SMC reset on my macbook pro.

All of these experiences are leading me to believe that Kali, running on kernel version 3.18 is simply not compatible with current versions of the other software involved.

I would be greatful for any help. Here are 5 links to forums/methods I have used, none of which worked so far.

https://superuser.com/questions/671747/cant-install-parallels-tools-on-debian-7-2-0

https://forum.parallels.com/threads/parallels-tools-9-0-24229-and-kali-1-0-7.303731/

forum (dot) parallels.com/threads/problem-installing-tools-on-3-18-kernel.327491/

forum (dot) parallels.com/threads/trying-to-install-parallels-tools-on-kali-linux.327779/

download (dot) parallels.com/desktop/v6/docs/en/Parallels_Desktop_Users_Guide/22570.htm

EDIT #1: For a look at the log file, please follow the link in the first comment below from AustinMW: naxrevlis (dot) com/?p=19

EDIT #2: I have now just decided to dual boot from SSD, which is working as one would hope. I did manage to make a bootable Kali USB, using a program called Rufus in Windows, which created both EFI and BIOS boot methods.

  • I can't help, but I'm also having similar issues on Parallels 10.1 with Kali 1.1.0a 3.18. I get, "Some components needed for Parallels Tools installation are missing in your system. Do you want to download these components automatically?" And then, "An error occurred while installing Parallels Tools. Please go to /var/log/parallels-tools-install.log for more information." I've also tried the install notes here: naxrevlis.com/?p=19. I've posted my error logs there, do you have any of the same warning messages? – Austin Jul 15 '15 at 4:25
  • I have posted my log there under yours. Although I get the same error message, there do seem to be some differences in the log. I can't make much of it though right now... – n1k31t4 Jul 15 '15 at 5:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.