Using Linux Mint (Cinnamon Desktop) I have not been able to connect to the eduroam wireless university network. The reason is that I can't find a proper way to enter the respective network settings, i.e. changing security settings as well as filling in my account name and password.

This is what I get (apologies for the Dutch language): enter image description here

As you can see, some other networks (in this case: UU visitor) let me change settings if I want to. edit: it does not prompt me for the settings when I try to connect to the network

How can I access the settings of any network which does not provide the settings icon? Or if you happen to be an expert on eduroam, how can I access that network specifically?

  • If you try to connect to eduroam it does not prompt you for the settings/credentials? Some of these graphical wizard tools may not have a so visible way to configure a network you have never used, but they will ask for the settings the first time you try to connect to it.
    – njsg
    Jul 14, 2015 at 9:38
  • @njsg Oh, I should have added that for clarity: no, it does not prompt me for the settings/credentials. If you have a suggestion about how to make that prompt appear, it would be great :)
    – Lena
    Jul 14, 2015 at 9:43
  • 1
    I have the same problem with the new network manager :/
    – Lukasstr
    Jul 15, 2015 at 9:13
  • Just FTR for those not familiar with eduroam, it uses 802.1X + EAP.
    – arved
    Jul 17, 2015 at 13:20

4 Answers 4


I'm using Linux Mint (since 17.1)1 and followed this guide which was working for me, so far.

(Please leave a comment if this is working for other LM releases as well so that I can update this answer)

What I did in a nutshell..

Started the Network Connections2 app:

enter image description here Added a new Wi-Fi network connection:

enter image description here enter image description here Entered the following credentials:

enter image description here enter image description here

I think that was it.

1 As comments indicate/confirm, this should also work with the following OS versions: 17.2, 18.0, 18.1 and 18.3

2 Note: Make sure you open "Network Connections" instead of "Network"

  • Nope :( this only works in 17.1 with the old network manager... Not in 17.2
    – Lukasstr
    Jul 22, 2015 at 13:11
  • That's unfortunate...is 17.1 and 17.2 really that different? Jul 22, 2015 at 13:17
  • 1
    @Lena So when you open the 'Network Connections' app (2nd pic above) Then the 'Add' button is greyed out? Or when you've added a new connection, the 'Edit' button is greyed out? Or does the 'Network Connections' doesn't even appear? You might want to start the app with sudo nm-connection-editor then but I don't think it's gonna help much... It seems however that this problem on AskUbuntu is the same as yours so I expect the answers apply to you as well... Let me know if it works. Jul 24, 2015 at 12:29
  • 1
    Worked for me on linux mint cinnamon 17.3. Left the "CA certificate" blank and ignored the warnings regarding that (do this at your own risk).
    – kidmose
    Jul 19, 2017 at 7:48
  • 2
    Worked also on Linux Mint 18.1 for TU Delft eduroam.
    – Angelorf
    Sep 14, 2017 at 13:16

If you go to https://cat.eduroam.org/ you can select your university and it will download a script.

One reason that you may want to use the script is because it will download the right CA. I tried the previous answers before trying the script and it appeared that the previous did not work because my institution uses the digicert root.

From the terminal (after downloading from Chrome) I did:

  1. cd ~/Downloads
  2. chmod +x eduroam-linux-USU.sh (change this to the script for your university)
  3. ./eduroam-linux-USU.sh (again, change the script name to the one you downloaded)
  4. Follow the on screen prompts
  5. You should now be able to connect

Note: This is the official Eduroam script and not some 3rd party script. That is, it was designed by the company that is providing Eduroam access. On that note, they are probably not looking to do anything malicious.

I did look at the script for some people's security concerns and though I'm not well versed in shell scripts it looks like what it does the following:

  • Creates a directory named ".cat_installer" in your home folder
  • Adds a certificate named ca.crt to ".cat_installer" directory
  • Adds a PFX file cnamed "user.p12" to the ".cat_installer" directory
  • Adds network settings for Eduroam including: ssid, key_mgmt, pairwise,group, eap, ca_cert, identity, subject_match, phase2, and password
  • Tries to remove any previous networks defined as eduroam
  • 1
    I feel it would be a good idea to include a summary of what the script does (because you've checked that before running it, right?) if you're posting an answer like this. Encouraging people to just download a script from somewhere and run it makes the inner security maniac inside me want to scream.
    – Erathiel
    Sep 10, 2015 at 16:11
  • @Erathiel I did not check it, it is from Eduroam itself and not some shady third-party. I have checked it now and have updated the answer. Sep 10, 2015 at 16:43
  • I'm not familiar with Eduroam, hence the confusion :) Thank you for updating your answer.
    – Erathiel
    Sep 11, 2015 at 9:51
  • Unfortunately after executing the official script and completing the prompt I still get the same error.
    – Tianyi Shi
    Feb 9, 2021 at 0:53

Just installed LinuxMint 17.2 on a Dell Latitude E5520, and above instructions were found correct for connecting to eduroam (Erasmus University Rotterdam); Make sure you open "Network Connections" instead of "Network"; Also, after adding the "eduroam" Wifi network, on the Wireless networking page a "Preferences" button appears next to the eduroam network.


After reading @travis-pessetto 's answer to the question "Can't access Eduroam wireless internet connection SETTINGS (Linux Mint 17)", I thought it was worthwhile to note that the CAT eduroam installer only worked for me with root privileges: sudo ./eduroam-linux-<your_institution>.sh

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .