3

I haven't found any solution working so far :( What I've tried so far was follow steps from the manual.

First I installed all required packages (at least I think so, naming isn't always the same) . List of packages:

  • pygtk2 (2.24.0-9)
  • python-configobj (4.7.2-7)
  • pygobject2 (2.28.6-11)
  • pygobject3 (3.8.2-6)
  • python-simplejson (3.3.3-1)
  • pysvn (1.7.6-10)
  • subversion-python (1.8.11-1)
  • subversion (1.8.11-1)

Second i tried running setup.py install where I was getting error on line 165 when icon cache is deleted and recreated. I couldn't find gtk-update-icon-cache-3.0 executable on my distro so I just changed the executable name with gtk-update-icon-cache. Not sure if that is the right way or not. Note: No rabbitvcs binary was found after running setup.py install command. I think the setup.py script could be a little more verbose :)

From there I followed nautilus-3 README. I couldn't find any nautilus-python package. Not sure how to deal with this problem, any hints? I did find this link, but I don't know what to do with it. I ignored the missing package and created /usr/share/nautilus-python/extensions manually and copied the RabbitVCS.py. Restarted nautilus without success :|

It's a shame no one is dealing with this problem, since the damn Windows got me hooked with tortoisesvn and unfortunately I also had to switch from CentOS 6 to CentOS 7.

0

I too struggled for installing rabbitvcs+nautilus but I ended with rabbitvcs+Thunar. To get it working on CentOS 7 do following:

Download following packages from here:

rabbitvcs-cli-0.14.2.1-5.el7.centos.noarch
rabbitvcs-core-0.14.2.1-5.el7.centos.noarch
rabbitvcs-thunar-0.14.2.1-5.el7.centos.x86_64
thunarx-python-0.2.3-5.el7.centos.x86_64

Open terminal as root user and run following commands

yum install thunar gtk-doc Thunar-devel
yum install meld pysvn python-dulwich python-simplejson subversion
rpm -ivh rabbitvcs-core-0.14.2.1-5.el7.centos.noarch.rpm rabbitvcs-cli-0.14.2.1-5.el7.centos.noarch.rpm thunarx-python-0.2.3-5.el7.centos.x86_64.rpm rabbitvcs-thunar-0.14.2.1-5.el7.centos.x86_64.rpm

open thunar explorer and check context menu, rabbitvcs menu should be available to you to serve.

Hope this serves the purpose you are looking for.

  • Thanks! Works, shame it's not nautilus + I have some side cases which thunar handles poorly, but that's already another topic. I was looking into using another file browser myself but gave up in the end. Did you came across any issues when using thunar on centos7 or rabbitvcs in that matter? – krizajb Aug 10 '15 at 10:25
  • Yes that's true about Thunar, I observed repobrowser crash several times but I managed to use by using browse button to enter repo url – Dipak Chaudhari Aug 12 '15 at 5:58
  • I've been noticing that commit&update options available in context menu aren't available past third level directory, i.e. root/source/module. Any clues? – krizajb Aug 14 '15 at 9:59
2

Based on guidelines from Dipak Chaudhari, I completely installed RabbitVCS and Nautilus.

  1. On terminal, install packages:

    yum install meld pysvn python-dulwich python-simplejson subversion
    

    (and maybe other packages if your system misses: pygtk, python-configobj, python-gobject, python-gtkspell, python-svn, git)

  2. Go to http://rpm.pbone.net, search and download (search in Fedora 19 and CentOS 7):

    rabbitvcs-cli-0.16-1.fc19.noarch.rpm
    rabbitvcs-core-0.16-1.fc19.noarch.rpm
    nautilus-python-1.1-4.fc19.x86_64.rpm
    nautilus-python-devel-1.1-4.fc19.x86_64.rpm
    rabbitvcs-nautilus-0.16-1.fc19.x86_64.rpm
    

    Then install them on terminal in the order as listed below (you can install on one line):

    rpm -ivh rabbitvcs-cli-0.16-1.fc19.noarch.rpm
    rpm -ivh rabbitvcs-core-0.16-1.fc19.noarch.rpm
    rpm -ivh nautilus-python-1.1-4.fc19.x86_64.rpm
    rpm -ivh nautilus-python-devel-1.1-4.fc19.x86_64.rpm
    rpm -ivh rabbitvcs-nautilus-0.16-1.fc19.x86_64.rpm
    
  3. Restart the system. Open File Manager. Create new folder.

    Right click on that folder and you can see RabbitCVS on the submenu.

  • All those install without error, albeit "core" must be installed first. However, even after reboot I see no menu in Nautilus. – robross0606 Apr 20 '17 at 13:25
  • This suggestion doesn't work with Nautilus3. – robross0606 Apr 20 '17 at 13:27
  • Worked for me. I could not find nautilus-python and nautilus-python-devel as mentioned in the answer. However, it asked python2-rabbitvcs which I was able to find in that search location. – Rakesh N May 22 at 10:51
2

Adding an answer here as I can't comment on Hien Lee's without more reputation points. I followed Hien Lee's guide, but still had no luck on this. After looking at System messages I found that there was a python stacktrace getting logged, with a dependency on gtkspell version 3. After uninstalling gtkspell and updating to the gtkspell3 library, this worked

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.