0

We've purchased several new Lenovo N21 chrombooks to run Python workshops for inmates in the local jail. Trying to install Crouton, Debian, and Anaconda to prepare. All require developer mode and root access. We are unable to get root access as expected. Progress so far:

  1. Powerwash + enable developer mode. Leave root password blank
  2. Switch to the beta channel and update to ChromeOS 44.02403.81 beta (64-bit)
  3. Browsing as guest, open Crosh (ctrl+alt+t) and run shell
  4. Alternatively open VT2 shell (ctrl+alt+F2)

All further instructions for both Crouton and Anaconda require sudo. We tried logging in with chronos for user and blank for password as per instructions (the command line shows chronos@localhost). Alternatively we've tried setting the root password in step 1, along with a variety of default passwords like facepunch, chronos, chromium, password, and test0000. All of these approaches to gain sudo privileges result in the incorrect password attempt message. We tried also the stable and the unstable channels along with setting up a default user with same results.

About Chrome OS additionally shows:

  • Platform 7077.76.0 (Official Build) beta-channel enguarde
  • Firmware Google_Enguarde.5216.201.10

What is the default root password or password for the chronos user in this case?

2 Answers 2

2
  1. Browsing as guest, open Crosh (ctrl+alt+t) and run shell

Does that work? Can you log in as 'chronos' without a password?

Alternatively open VT2 shell (ctrl+alt+F2)

Can you log in as 'chronos' in VT2 without password?

If so, you should be able to use 'sudo' without a password in that environment.

Have you setup any Google accounts and logged in and tried ctrl+alt+t, then shell?

0

After much struggle I realized the problem was switching to root (su root) with the password supplied during the initial configuration. I was then able to run chromeos-setdevpasswd with elevated privileges to change the default chronos password.

I took detailed notes here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .