6

I'm trying to configure 'Offloading Graphics Display with RandR 1.4' but xrandr detects only Intel video card:

$ xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x45 cap: 0x2, Sink Output crtcs: 3 outputs: 3 associated providers: 0 name:modesetting

Video cards (laptop Acer Aspire V3-772G):

# lspci | grep -E 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation Haswell Integrated Graphics Controller (rev 06)
01:00.0 3D controller: NVIDIA Corporation GK107M [GeForce GT 750M] (rev a1)

OS:

$ cat /etc/slackware-version 
Slackware 14.1
# uname -a
Linux darkstar 3.15.1-big_btz #3 SMP Mon Jul 14 15:56:31 EEST 2014 x86_64 Intel(R) Core(TM) i7-4702MQ CPU @ 2.20GHz GenuineIntel GNU/Linux

X:

$ ls -l /var/log/packages/xorg-server-*
-rw-r--r-- 1 root root 8245 Feb  8 07:52 /var/log/packages/xorg-server-1.14.3-x86_64-3_slack14.1
-rw-r--r-- 1 root root  712 Feb  8 07:52 /var/log/packages/xorg-server-xephyr-1.14.3-x86_64-3_slack14.1
-rw-r--r-- 1 root root  933 Feb  8 07:52 /var/log/packages/xorg-server-xnest-1.14.3-x86_64-3_slack14.1
-rw-r--r-- 1 root root 1027 Feb  8 07:52 /var/log/packages/xorg-server-xvfb-1.14.3-x86_64-3_slack14.1

Kernel config (full config):

# zcat /proc/config.gz | grep CONFIG_DRM
CONFIG_DRM=m
CONFIG_DRM_KMS_HELPER=m
CONFIG_DRM_KMS_FB_HELPER=y
CONFIG_DRM_LOAD_EDID_FIRMWARE=y
CONFIG_DRM_TTM=m
CONFIG_DRM_I2C_CH7006=m
CONFIG_DRM_I2C_SIL164=m
CONFIG_DRM_I2C_NXP_TDA998X=m
# CONFIG_DRM_TDFX is not set
# CONFIG_DRM_R128 is not set
# CONFIG_DRM_RADEON is not set
# CONFIG_DRM_NOUVEAU is not set
# CONFIG_DRM_I810 is not set
CONFIG_DRM_I915=m
CONFIG_DRM_I915_KMS=y
CONFIG_DRM_I915_FBDEV=y
CONFIG_DRM_I915_PRELIMINARY_HW_SUPPORT=y
# CONFIG_DRM_I915_UMS is not set
# CONFIG_DRM_MGA is not set
# CONFIG_DRM_SIS is not set
# CONFIG_DRM_VIA is not set
# CONFIG_DRM_SAVAGE is not set
CONFIG_DRM_VMWGFX=m
CONFIG_DRM_VMWGFX_FBCON=y
# CONFIG_DRM_GMA500 is not set
# CONFIG_DRM_UDL is not set
# CONFIG_DRM_AST is not set
# CONFIG_DRM_MGAG200 is not set
# CONFIG_DRM_CIRRUS_QEMU is not set
# CONFIG_DRM_QXL is not set
# CONFIG_DRM_BOCHS is not set
# CONFIG_DRM_PTN3460 is not set

Nvidia (install log):

$ nvidia-settings -v

nvidia-settings:  version 352.21  (buildmeister@swio-display-x64-rhel04-13)  Tue Jun  9 22:42:41 PDT 2015
  The NVIDIA X Server Settings tool.

  This program is used to configure the NVIDIA Linux graphics driver.
  For more detail, please see the nvidia-settings(1) man page.

Xrandr:

$ xrandr -v
xrandr program version       1.4.1
Server reports RandR version 1.4

P.S. I'm not sure how to check that appropriate driver interfaces are presented

o A Linux kernel with CONFIG_DRM enabled and the appropriate driver
     interfaces present:

        o drm_gem_prime_export

        o drm_gem_prime_import

        o gem_prime_pin

        o gem_prime_get_sg_table

        o gem_prime_import_sg_table

        o gem_prime_vmap

        o gem_prime_vunmap
2

I have a similar setup on Slackware:

# lspci | grep -E 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation Haswell Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GK106M [GeForce GTX 765M] (rev ff)}

And my xrandr only shows one card:

xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x47 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 4 outputs: 4 associated providers: 0 name:Intel

but my nVidia card still seems to be working (I use bumblebee / optirun)

$ optirun glxinfo | grep "OpenGL renderer"
OpenGL renderer string: GeForce GTX 765M/PCIe/SSE2
$ optirun glxgears -info
GL_RENDERER   = GeForce GTX 765M/PCIe/SSE2
GL_VERSION    = 4.5.0 NVIDIA 352.30
GL_VENDOR     = NVIDIA Corporation

and uses the Intel card if I don't run optirun:

$ glxinfo | grep "OpenGL renderer"
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile
$ glxgears -info
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
GL_RENDERER   = Mesa DRI Intel(R) Haswell Mobile 
GL_VERSION    = 3.0 Mesa 10.5.4
GL_VENDOR     = Intel Open Source Technology Center

See http://docs.slackware.com/howtos:hardware:nvidia_optimus for setup instructions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.