4

I'm unsure if this is hard or software issue but I really need to find out.

I was running Windows 8.1 for some time, then swapped to Linux mint with kernel 3.13 which worked fine. I updated kernel to 3.19 without issues. Later I swapped to 4.0.

One day, my network stopped working, (eth0) does not matter if I'm docked in station or using a cable. (this is at work, so we have many desks that I use..) Swapped to Elementary OS, 3.16 - Same issues.

I tried to downgrade kernel, update my network drivers, update NetworkManager etc. Nothing works.

I have checked:

  • logs (syslog)
  • dmesg
  • New kernel
  • New drivers (updated grub, initramfs)
  • taken traffic dumps which shows broadcast traffic and my outgoing (but no other incoming) traffic

... etc I cannot find anything interesting, the interface shows traffic being sent out but it does still not seem to leave my computer really.

Currently I have a script that brings eth0 down / up and restarts dhclient which is the only solution that works.

IPv6 is disabled on all possible levels. wifi does not have this issue!

Network:   Card-1: Intel Ethernet Connection I218-LM
           driver: e1000e v: 2.3.2- port: 4080 bus-ID: 00:19.0

I'm also using VMware and bridge to eth0 for my virtual windows. (tried VirtualBox and VMware, does not change, so I don't think they ruin my eth0 connection)

Anyone have any tip on how to troubleshoot this further? Only thing I know is to install windows again and see if it has the same issue (in case of HW failure) but that's a buttload of work right now.

  • What happens when the network stops working? Is there a change in your system's configuration (e.g. the interface goes down, the routing table is modified, the firewall rules change, …)? Do the packets stop coming out? Do the packets stop being received at the other end? Are incoming packets seen on the local network? Are they delivered to your system? Use tcpdump -i eth0 or Wireshark to observe network traffic, both on your machine and on another machine that should be seeing local traffic. – Gilles Jul 12 '15 at 13:07
  • I did a tcpdump earlier though I did not check on an end device as I had none to test with at my office. What i saw was local traffic beeing sent out but none received. Anyway solved by removing networkmanager now! – Philip Wiberg Jul 13 '15 at 17:34
2

Networkmanager was the issue. Update helped because it rendered my NM unusable. I just set dhcpaddress through "dhclient eth0" and it worked.

So I uninstalled NM and installed wicd, to have a gui.

Works like a charm.

Advice if u have the same issue: Remove NetworkManager.

1

Perhaps a very simple suggestion and not sure if this will help matters. But perhaps try a liveCD, since that requires practically no work and wont require you messing with your current OS?

If a liveCD doesn't work either I would think thats a good indicator its hardware related. Since Linux Mint 3.13 or 3.19 worked try and grab a live CD of those version.

  • Sure thing, will do that and use Mint with 3.13 kernel to see if it in fact might be related. – Philip Wiberg Jul 12 '15 at 8:05
  • Ok, it works fine. Great news. My next step now is to remove VMware to see if the bridge there is causing any possible problems. Any other tips welcome! – Philip Wiberg Jul 12 '15 at 11:05
  • I updated network-manager and its been working for about two hours now which is a long time record. Will see if it holds the day and tomorrow perhaps. – Philip Wiberg Jul 13 '15 at 13:27
  • See my answer, remove networkmanager=success.. Installed wicd instead. – Philip Wiberg Jul 13 '15 at 17:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.