6

I am running Debian 7.1. I tried to apt-get install -f, and messed up. All command line returns

ln: relocation error: /lib/arm-linux-gnueabihf/libc.so.6: symbol _dl_find_dso_for_object, version GLIBC_PRIVATE not defined in file ld-linux-armhf.so.3 with link time reference

It seems some soft links are broken, but I do not know how to resolve it.

0

This looks like you broke files from the glibc package, resulting in nothing wanting to start anymore. Unfortunately, that's extremely difficult to fix from the running system. The easiest way to fix it is usually to install the storage (SD card, hard disk, ...) in a different system, and recreate the links there.

Alternatively, you can boot from a rescue or installation medium and recreate the links from a shell on that system.

0

If you have the sash shell installed, it should run just fine - it is a fully staticlly linked shell, and it has an internal ln command available (accessible as -ln). Other possibility is busybox-static. Though the best bet seems to boot from a live medium (might be nontrivial on ARM!) and install the correct libc6 package.

0

I've had this problem before. What I did that seemed to fix the problem was turn up the gpu memory, which can be done this way this is the raspberry pi configuration (I am using raspberry pi os buster which is basically Debian 10) which can be found by clicking on the applications icon in the top left corner of the screen an going to preferences, and raspberry pi configuration, and then performance. Then go to GPU Memory, and raise it 25 to 50 numbers. It is something like that if you have a slightly different version of Debian.

This is the raspberry pi configuration (I am using raspberry pi os buster which is basically Debian 10) which can be found by clicking on the applications icon in the top left corner of the screen an going to preferences and raspberry pi configuration and then performance. It is something like that if you have a slightly different version of Debian.

There is a commandline way to do it as well. That is to enter

sudo nano /boot/config.txt

into a terminal window and scrolling to the bottom, where you will find:

this is overclocked, but look at the "gpu_mem" line, and raise about 25 to 50 numbers. then, hit Ctrl+x and then y and then enter.

This is overclocked, but look at the gpu_mem line, and raise about 25 to 50 numbers. then, hit Ctrl+X and then y and then Enter. That should fix it; it did for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.