1

I am trying to connect a WIFI usb to my guest OS which is Kali Linux. I am using TL-WN822N for this purpose.

I have followed these steps,

  • Go to USB option in settings
  • Enable USB Controller
  • Enable USB 2.0 (EHCI) Controller. (I have also tried without this option enabled)
  • Added USB to the list.

Now, before starting the Kali Linux, the light on my USB is blinking but as soon as I start the OS the light on the USB Wifi goes off and the device name disappears from the Device Manager of my Host OS.

Once the OS is started, I go to Device > USB and select the USB device but I get this error:

Failed to attach the USB device Realtek USB WLAN [0200] to the virtual machine Linux.
USB device 'Realtek USB WLAN' with UUID {8cf25dd1-a201-4320-b459-af7a63f481c4} is busy with a previous request. Please try again later.
Result Code: E_INVALIDARG (0x80070057)
Component: HostUSBDevice
Interface: IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

I have tried connecting the USB Wifi to both USB 3.0 and 2.0 ports but neither works.

I have also tried various other solutions from VirtualBox forums but none of them helped.

My Host OS is Windows 7 64-bit.

3
  1. Open registry editor (run>regedit)

  2. Browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{36fc9e60-c465-11cf-8056- 444553540000}

  3. Delete the key named "upper filters"

  4. Restart the PC


If you still have issues then update Kali by running these commands in terminal:

apt-get update 
apt-get upgrade
0

I've got similiar problem with Windows 10 Pro x64 as Host and Kali Linux 2019-2 as Guest, with the difference that my Component and Interface were:

Component: HostUSBDeviceWrap
Interface: IHostUSBDevice

I've found the solution in this post https://forums.virtualbox.org/viewtopic.php?f=6&t=80452 To be more precise the right steps were this ones

1) In VirtualBox, Add new filters with the Product ID , and Vendor ID, put Any "in Remote and leave blank the rest of fields"

2) Close VirtualBox

3) Go to your installation Directory: C:\Program Files (x86)\Oracle\VirtualBox\drivers\USB

4) Go to both Folder (device and filter), and in both folder : Right-click on the file extension *.inf ( VBoxUSBMon.inf and VBoxUSB.inf) and click "Install "

5) Start VirtualBox then your VirtualMachine

After this, it's working again.

Hope it helps!

0

If this doesn't work and you have asus MOBO with ai charger and boost 3.0 usb go into your win settings apps aisuite3 and uninstall ai charger and ready boost, worked for me! I did both but removing charger alone did not fix, had to get rid of readyboost for 3.0 and that did it. Charger may be ok, but i'm not putting back in because I don't use it anyways. Hope this helps someone.

New contributor
WiKKiD1 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.