7

Hostapd keeps giving me this error:

nl80211: Could not configure driver mode nl80211 driver initialization failed. hostapd_free_hapd_data: Interface wlan0 wasn't started

I'm on Debian 8. I googled for hours and can't find a fix that works with Jessie.

1
  • I found a solution in niwi.cz/clanky/it-poznamky/…. Try it and post if you could get it solved. It worked for me. Good luck
    – user167679
    Apr 26, 2016 at 17:20

2 Answers 2

8

I had the same issue on my raspberry-PI. I could not find any proper solution but I did come up with a slightly dirty way to solve the issue:

  1. slightly modified solution from "adrianTNT" here on Ask Ubuntu

    airmon-ng check
    

    and the process I needed to kill was wpa_supplicant so

    killall wpa_supplicant
    
  2. I had to run this command to successfully start hostapd

    hostapd /etc/hostapd/hostapd.conf
    

    instead of the more common way service hostapd start which always failed.

4

This message appear also if hostapd is still running for some reason in the background. So try sudo killall hostapd.

2
  • For me, "service hostapd restart" did not work. This did the trick.
    – jous
    Oct 10, 2017 at 15:01
  • It indeed was hostapd in the background, thank you! Once terminated, all other instances worked well. Just in case, the error messages were (in order): nl80211: kernel reports: Match already configured nl80211: Could not configure driver mode nl80211: deinit ifname=wlx0 disabled_11b_rates=0 nl80211 driver initialization failed. wlx0: interface state UNINITIALIZED->DISABLED wlx0: AP-DISABLED wlx0: CTRL-EVENT-TERMINATING hostapd_free_hapd_data: Interface wlx0 wasn't started
    – Faither
    May 31 at 12:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.