Hostapd keeps giving me this error:

nl80211: Could not configure driver mode nl80211 driver initialization failed. hostapd_free_hapd_data: Interface wlan0 wasn't started

I'm on Debian 8. I googled for hours and can't find a fix that works with Jessie.

  • I found a solution in niwi.cz/clanky/it-poznamky/…. Try it and post if you could get it solved. It worked for me. Good luck – user167679 Apr 26 '16 at 17:20

I had the same issue on my raspberry-PI. I could not find any proper solution but I did come up with a slightly dirty way to solve the issue:

  1. slightly modified solution from "adrianTNT" here on Ask Ubuntu

    airmon-ng check
    

    and the process I needed to kill was wpa_supplicant so

    killall wpa_supplicant
    
  2. I had to run this command to successfully start hostapd

    hostapd /etc/hostapd/hostapd.conf
    

    instead of the more common way service hostapd start which always failed.

This message appear also if hostapd is still running for some reason in the background. So try sudo killall hostapd.

  • For me, "service hostapd restart" did not work. This did the trick. – jous Oct 10 '17 at 15:01

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.