I am using xfce4 on Fedora 22. I am able to use my volume keys to change the volume and use my mute key with no issue. However, no notification is showing on the desktop indicating volume change. Other notifications are working however.

A few more details: I am using an Apple keyboard. I remapped it so it uses the function keys by default. Therefore, I use a keyboard shortcut with a command, for example, the minus volume key amixer -D pulse sset Master 5%-, etc. The volume notifications were not working anyways before remapping the keyboard to use fn by default.

This same setup (fn enabled by default with keyboard shortcuts for volume and mute) has worked and shown notifications with no problem on Linux Mint 17 and on Xubuntu 14.04. I currently dual boot with Xubuntu 14.04, and I noticed that it doesn't even have an xfce4-notifyd.xml file.

Any ideas would be much appreciated.

You need to run xfce4-volumed with applied pulse audio patches.

Please be aware that with the deprecation of gstreamer0.10 and its mixer interface in favor of gst1.0, xfce4-mixer and xfce4-volumed became deprecated. Use xfce4-pulseaudio-plugin and pavucontrol instead.

  • I am running xfce4-volumed, and I have xfce4-pulseaudio-plugin and pavucontrol installed. I also have xfce4-mixer installed. By saying "with applied pulse audio patches" do you basically mean the latest version of xfce4-volumed and xfce4-pulseaudio-plugin? Would you know where I could find needed patches? I have been unable to find them. Thank you – jbrock Jul 22 '15 at 20:46
  • No, that's not what I meant. Upstream xfce4-volumed only knows about ALSA, so the *buntu guys forked and patched it to include support for PulseAudio. But with the advent of xfce4-pulseaudio-plugin for the panel, you don't need xfce4-volumed anymore, because it can show notifications by itself. Just add it to your panel. And since xfce4-mixer doesn't have support for Pulse, but only for ALSA, you should replace it with pavucontrol. – killermoehre Jul 22 '15 at 21:41
  • Great news, there is new xfce4-volumed-pulse plugin! – yanpas Sep 30 '17 at 16:25

Not sure about PulseAudio, but this thing always was glitchy for me so I stick to just Alsa now. I googled a bit and you might need http://freedesktop.org/software/pulseaudio/pavucontrol/ to make it work.

There is a known bug where amixer doesn't affect xfce4-mixer, and pavucontrol most likely patches it.

  • I never could get it to work. I tried various things. I settled for just using the PulseAudio Panel Plugin instead. Thank you – jbrock Jul 13 '15 at 5:21

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.