2

I have an iMac mid 2011 running OSX and I am trying to install Arch Linux following this guide. I successfully set up a dual boot last year following a similar procedure but now I can't even start since I get a kernel panic while booting from the live usb installation of archiso: right before the login prompt. I'm 100% sure the image is not corrupted (I checked the signature and booted it on another pc).

Since last year it worked I tried every old release and I isolated the one that introduced the problem: it's 2015-05-01 kernel 4.0.1. Older versions boot fine and I can complete the installation but after a restart I get the kernel panic anyway.

I don't know what to do because I can't change any setting on the archiso image and the stack trace goes so fast I can't even record it: in a glimpse I have noticed "null pointer dereference", "scheduling while atomic" and "fixing recursive fault but reboot is needed”.

How can I debug it? And, possibly, how do I solve this issue?

  • 1
    It sounds like your system is for whatever reason incompatible with the most recent kernels. Try installing linux-lts rather than just linux as your kernel package via pacman or pacstrap or whatever you use to source your installation packages. – mikeserv Jul 10 '15 at 2:32
  • linux-lts did the job but I still like to know what is causing this. – Rnhmjoj Jul 12 '15 at 21:32
  • well, now your system works you can apply yourself to that problem. You should probably start with reviewing changelogs and see if anything clues you. – mikeserv Jul 12 '15 at 21:37
  • I tried Kdump to dump the memory on kernel panic but I couldn't get it to work so I managed to get a decent camera and recorded the thing at 120Hz. I found it: bugzilla.redhat.com/show_bug.cgi?id=1240463 – Rnhmjoj Aug 9 '15 at 4:33
2

I installed the linux-lts package as suggested by @mikeserv from chroot and I set it as the default boot option from the grub configuration. This way I could boot nicely into linux 3.14 and complete the installation process. The vanilla linux kernel is installed alongside with the LTS version so using the "advanced options" from the grub menu I could still boot with linux 4.0 and see the system crash.

I then tried using Kdump to make a memory dump of the machine during the kernel panic but for some reason I still don't know kexec won't start on the kernel I recompiled with debug options.

Eventually I manage to read the kernel panic log the hard way: by recording it with a high-frame rate camera and I was able to identify the driver that caused the crash: radeon_audio_detect. The bug has been reported several times and it seems to affect all macs with a radeon gpu and other systems as well. A patch for it as already been added to the kernel in 4.2rc5

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.