1

Due to some historic reason, I am running Xorg-1.4 with kernel 2.6.32.21 for an old board. On this board, If I start the X then, mouse works very well. But keyboard fails to run. Only "numpad" works and not any other keys.

I am attaching here pastebin link for lsmod, Xorg.0.log and xorg.conf output. If anything required, I will provide the info.

This is VIA board, I had blacklisted via_chrome9 to start the X with viafb only.

UPDATE:

When I run xev, all the keys get detected. But fails to get print in any other apps (I'm trying with xterm). Even if, I take VNC of this machine, then in VNC Session also, I'm not able to use keyboard.

0

I've had this problem before as well w/ a bluetooth keyboard. It was infuriating because I only ever connected it twice: the first time it worked fine, but, a month later, on the second occasion, only some keys worked and those that did only came out as numbers.

Of course, in my case, I had a little extra motivation to find the cause because I knew it could work - so I did a lot of googling on it. I eventually came across a few threads which mentioned that a previous keyboard connection might have modified the num-lock setting, and now this one couldn't. One mentioned setleds.

My solution was to exit X to its vt and run ...

setleds -num

... as root. Afterward I disconnected and reconnected the keyboard, ran startx, and the keyboard worked just as it did the first time.

sigh I never did have cause to connect it a third time. I don't know why I buy that crap.

  • I did that, what you said. But got the same result. Only numpad is working and neither the alphabets nor any special character. – SHW Jul 10 '15 at 6:28
  • @SHW - That's how mine was - only it was a small keyboard and so the numpad was layered over the center of the keyboard. When I pressed buttons I only got some keys to work - and they were all like .0-9+=/ and so on. Maybe I got the command wrong from memory - it was a couple months ago. I'll look at man setleds again - you might do the same. You might also try +num on the meantime. – mikeserv Jul 10 '15 at 6:31
  • Sure. I will but I do not see any connection between "setled" and this issue :-( – SHW Jul 10 '15 at 6:33
  • @SHW - well, it's not so much about the leds, as it is the kernel's interpretation of the keyboard state. Or at least it was for me. By the way, you'll want to make sure that the vt you change is the same X launches on. You use setleds ... </dev/tty[num] to ensure the input tty is the one for which you modify the keyboard state. And so you might not need to exit X at all. – mikeserv Jul 10 '15 at 6:37
  • @SHW - see this dev thread about how vt led settings are handled in kernel. – mikeserv Jul 10 '15 at 7:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.