I have a small problem with Elementary OS 0.3 (Freya). Whenever I connect to the network, an application captive-login used to run. I removed that application by deleting the executable. Now whenever I connect to the network, google chrome opens 4 tabs - all going to start.elementaryos.org .

How can I prevent google chrome from opening these tabs, or remove captive-login in a way that won't cause this?

  • Workaround for start.elementaryos.org: add an entry like start.elementaryos.org to your /etc/hosts file - then no process will easily access that page. You could, of course, also set your start/home page in your web browser and/or its system configuration file(s) and/or your desktop manager settings.
    – Ned64
    Sep 8, 2015 at 14:56

2 Answers 2


Disabling the popup by crippling the executable is discouraged when there's a package manager. You don't know what else will break and updates may eventually reintroduce the file when you least expect it.

Instead you should find the package providing captive-login and examine what other files it provides, usually with Debian derived systems you'll find that large software suites are split into several smaller packages.

You can find which package captive-login belongs to with

dpkg -S $(which captive-login)

You should then list the other files it contains with

dpkg -L capnet-assist

In this case you'll see the capnet-assist does pretty much nothing else than providing the captive-login executable and some documentation for it. Knowing this you can then safely choose to remove the package capnet-assist, for example with

sudo apt-get remove capnet-assist

Now the package manager is aware of the change and will warn you if any other package depends on capnet-assist, in addition to not restoring the file next time capnet-assist is upgraded.


You can stop "captive-login" with the following steps:

  1. First delete sudo rm /usr/bin/captive-login or make backup.
  2. Create a new captive login executable: sudo nano /usr/bin/captive-login
  3. Write the following:

    exit 0
  4. Permissions for the new captive-login executable: chmod 777 /usr/bin/captive-login

These steps work for me, I don't know if this bug is already solved.

  • Alternatively, sudo cp -p /bin/true /usr/bin/captive-login to make it appear as if the file is there. Then you need to disable updating that package (blacklist in your package manager?), or repeat the procedure after each update that restores the file.
    – Ned64
    Sep 8, 2015 at 14:52
  • Wow. This actually helped. Thanks a lot. I'd been struggling with this issue for way too long. Thank you.
    – Suhas
    Sep 9, 2015 at 12:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .