1

I have 4GB USB flash drive stick plugged into laptop on debian 8.1. It contains one bootable partition 2GB created and formatted as FAT16 in Windows. What only I did try everything didn't. Maybe I am doing something wrong? What I tried:

  • mount -t msdos /dev/sdb1 /media/usb1
  • mount -t vfat /dev/sdb1 /media/usb1
  • added line "/dev/sdb1 /media/usb1 vfat defaults 0 0" to file /etc/fstab, then mount -t vfat /dev/sdb1 /media/usb1
  • added line "/dev/sdb1 /media/usb1 msdos auto" to file /etc/fstab, then mount /dev/sdb1 or mount /media/usb1

And every time I got the same error:

mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.

UPDATE:

qet@qet-PC:~$ sudo fdisk -l /dev/sdb

Disk /dev/sdb: 3.9 GiB, 4194304000 bytes, 8192000 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x6da2a859

Device     Boot Start     End Sectors Size Id Type
/dev/sdb1  *       63 4209092 4209030   2G  e W95 FAT16 (LBA)
  • What does fdisk -l /dev/sdb show when the card is inserted but not yet mounted? – John Jul 8 '15 at 13:53
  • john, post is updated – Qeeet Jul 8 '15 at 13:58
1

Point three and four don't make sense:

  • /dev/sdb1 /media/usb1 vfat defaults 0 0 is ok, but is mounted with mount /dev/sdb1 or /media/usb1
  • /dev/sdb1 /media/usb1 msdos auto does not make sense, because "msdos" and "auto" are both for the filesystem type. You could try /dev/sdb1 /media/usb1 auto defaults 0 0 here. "noauto" in the options (here the "defaults" field) would mean "don't mount it automaticaly" and not "don't choose the fs type automatically".

Entrys in fstab have all the information needed for the mount command, so these are mounted only with "mount TARGET" or "mount SOURCE".

  • does not work either – Qeeet Jul 13 '15 at 8:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.