4

I'm using linux mint 17 and I want to prevent a service from starting on boot.

I can stop the service with,

/etc/init.d/<service_name> stop

but it will start again on a reboot

On centos7 I would use the following command

systemctl disable <service_name>

How do I do this on mint 17 ?

6

For Linux Mint 17 based on Ubuntu you have to use this because it uses upstart as it is the way on Ubuntu 14.04 LTS:

echo manual | sudo tee /etc/init/<service_name>.override

For Linux Mint Debian Edition, it uses System V init, so you can issue:

update-rc.d -f <service_name> remove

It will remove completely the init scripts for the service. So if you are disabling it for a while and you want it in the future, better use:

update-rc.d  <service_name> disable

This only change the scripts of the service from signal start to signal kill, preventing it to start.

In the future it will change to systemd for both of them.

  • is the path /etc/init/<service_name>.override or /etc/init.d/<service_name>.override – lafferc Jul 8 '15 at 11:09
  • 1
    I can't test it right now but I'm very sure it is /etc/init/<service_name>.override – jcbermu Jul 8 '15 at 11:12
0

service service_name stop #just stop the service

service service_name disable #it should disable on runtime

The disable mode can cause some trouble

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.