0

I have tried multiple ways (referencing multiple forum posts) to install the latest version of R (3.2.1 "World-Famous Astronaut") on Linux Mint 17.1 (MATE).

I tried different sources lists, the most recent being:

deb http://cran.rstudio.com/bin/linux/debian wheezy-cran3/

but when I call:

apt-cache showpkg r-base-dev

with each of the ones I try, I always get:

3.0.2-1ubuntu1

as the most recent one available.

Has anyone been able to install 3.2.1 on Linux Mint? Thanks in advance.

  • Tom

2 Answers 2

1

You have a problem with the priorities of repositories.

Edit /etc/apt/preferences and add

Package: *
Pin: origin cran.rstudio.com
Pin-Priority: 900

And I would use

deb http://cran.rstudio.com/bin/linux/debian jessie-cran3/

Jessie and Wheezy are Debian version names.

As Mint 17 derives from Ubuntu 14.04, jessie (Release April 2015, Freeze November 2014) is the more natural source than wheezy (Release May 2013, Freeze June 2012). But thats just a personal opinion.

2
  • Thank you very much for the response! I have changed my deb as you suggested. Im not sure how to change my priorities though. When I go to /etc/apt/ I have a folder called "preferences.d" that only contains "official-extra-repositories.pref" and "official-package-repositories.pref" files.
    – Tommy
    Commented Jul 8, 2015 at 14:10
  • Continuing: from this link: askubuntu.com/questions/135339/… it seems that putting a specific .deb at the top of the source.list will control what version of something is installed. My sources.list currently only has the 'deb cran.rstudio.com/bin/linux/debian jessie-cran3/ ' that you suggested (I just did a fresh install of Mint 17.1), so would I even need to change the /etc/apt/preferences? Thanks!
    – Tommy
    Commented Jul 8, 2015 at 14:19
0

Ok, I figured it out. Thanks for all the help! I will post an answer here for anyone else trying to figure this out:

First I ran:

sudo gedit /etc/apt/sources.list

to get into my sources.list file. Then I added:

deb http://cran.rstudio.com/bin/linux/debian wheezy-cran3/

and also added the key: (thanks Dirk for the suggestion):

sudo apt-key adv --keyserver keys.gnupg.net --recv-key 381BA480

sudo apt-get update

then when I ran:

apt-cache showpkg r-base-dev

to see the available packages. The top one was:

Package: r-base-dev
Versions: 
3.2.1-1~wheezycran3.0(/var/lib/apt/lists/cran.rstudio.com_bin_linux_debian_wheezy-cran3_Packages)

so, finally I ran:

sudo apt-get install -f r-base=3.2.1-1~wheezycran3.0

which worked great!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .