3

I have KDE 4.14.2 on Debian 8.1 installed. When I have 3 layouts, switching META+Spacebar works perfectly. The problem begins when I am adding 4th layout, switching works incorrectly: I'm only able to switch from 1st->2nd layout, when I click switch layout shortcut in other cases (2,3,4) it does not work at all, so that 2->3, 3->4, 4->1 do not work at all.

I found some workaround to this: I have checked spare layouts option, so now I am able to switch between the most usable 3 layouts. But anyways I use 4. I couldn't find any solution of this on the internet. How to fix this?

  • It works perfectly fine on my Debian 8.1 with KDE 4.14.2. Detailed configuration at (unix.stackexchange.com/q/214273/101324). I guess you should not tick the box below the list of layouts, which is "Dispositions supplémentaires" in French, is that your "spare layout"? See screenshot. – Clément Jul 15 '15 at 20:01
  • I am not quiet sure if that is spare layouts, but here you can see what is spare layouts: kate-editor.org/wp-content/uploads/2013/10/keyboard-layouts.png And thank you for the replay, I will check that topic later – Qeeet Jul 16 '15 at 22:11
  • So I have it checked, and I have chosen the max value (3) in the text box. I use 4 layouts, and switching actually works incorrectly: it only goes from 1st layout to 2nd, after that shortcut switching does not work – Qeeet Jul 16 '15 at 22:14
  • So, does the proposed answer works? – Clément Jul 21 '15 at 19:48
2

Solution : untick the spare layout option for your layouts.

You should not use the spare layout option. This behaviour is perfectly sensible given that option (it is exactly what it is meant to do):

According to some KDE doc (pdf, html):

Spare layouts

This option can be enabled only if you have more than two layouts.

Spare layouts allow to toggle between small number of layouts easily while keeping more layouts handy close by. For example you might use 3 languages: English, Ukrainian and German but first two are used often and third one just occasionally. In this case you can configure first two as main layouts (setting Main layout count : 2) and German one as spare one - when you toggle with keyboard and left mouse button the switch will happen between main layouts only but you can always choose 3rd layout with context menu.

(…)

You should probably have a look as well at this question at superuser.sx

  • no, it does not work. As I said if it's unchecked, I'm only able to switch from 1->2 layout, when I click switch layout shortcut in other cases (2,3,4) it does not work at all, so that 2->3, 3->4, 4->1 do not work at all – Qeeet Jul 21 '15 at 20:10
  • Did you tried to check it? To check it then uncheck it? – Clément Jul 21 '15 at 21:51
  • 1
    yes, I have tried a lot of ways, except reinstalling kde :) – Qeeet Jul 21 '15 at 22:06
0

Well I've found templorary workaround. Just to use "Alternative shortcut" set as META+Spacebar.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.